Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

[open] Mouse cursor problem

edited November 2014 in OpenSesame

Hello! I am experiencing a strange problem and can't find a solution - although I don't know if it depends on OpenSesame. Briefly, my OpenSesame is installed on a Windows XP machine, but I use it remotely from an iMac (Yosemite OS) via Microsoft Remote Desktop, so the monitor on which the experiment is displayed is that of the Mac and also the keyboard and mouse are those of the Mac. The problem is that the mouse cursor moves in chunks of several pixels at a time (as if it was on a screen with much higher resolution).
This only happens if I run the experiment in full screen mode. I have tried to override the system cursor in the advanced setting but the problem is still there. And no - I cannot simply install opensesame on the mac and run the whole thing from there :)
Any ideas on where I can look for solving the problem? Thank you very much,
Paolo

Comments

  • edited 7:59PM

    Hi Paolo,

    I suspect that the problem is simply that the connection is too slow for a smooth remote-desktop connection, and that this is mostly a problem in fullscreen video mode (perhaps it uses a client-side cursor when running in window mode, I don't know).

    So this is probably related to your somewhat unusual set-up. What you could try though, is play around with the back-end settings and see if this makes the problem go away. For example, by selecting the legacy back-end and setting double buffering and/ or hardware surface to 'no'. You could even disable 'Draw window frame' and run OpenSesame with a resolution that matches the monitor's resolution. This way the window will cover the whole screen, thus effectively (but not technically) running in full screen.

    Cheers!
    Sebastiaan

    There's much bigger issues in the world, I know. But I first have to take care of the world I know.
    cogsci.nl/smathot

  • edited 7:59PM

    hi Sebastian and thank you very much for your reply. I don't think it is a connection speed problem (at least my impression is not this but I may be wrong). I will play around with the configuration and the settings and see if this solves the problem.

    cheers
    paolo

  • edited 7:59PM

    Hi @hasseb432

    The answer is simple: yes. Bonus tip: there are [tutorials(http://osdoc.cogsci.nl/tutorials/) to teach you how to use OpenSesame (e.g. to create RT experiments).

    Good luck!

Sign In or Register to comment.