Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

JASP for Arch/Manjaro or sources

Hey Guys,

Ive been trying to install JASP on my system running Manjaro Linux. I even tried using yaourt and cloning the git path available, but I dont seem to be able to get a working installation going. (Keeps failing at jasp-rbundle - doesnt exist in the AUR database). So I was wondering - where can I get my hands on the source tarball, if thats available? At least that way I can compile it by hand!

Guha

Comments

  • EJEJ
    edited 6:43AM

    Hi Guha,

    We only have JASP working for Ubuntu Linux. If you look on the GitHub issues list you can see our previous (failed) attempts to get it to work on another Linux version (I forgot the name). Right now we've decided to focus our efforts on adding new features -- our small programming team simply cannot support all the different Linux versions. Maybe at some point we'll get some help from the Linux community. I'll attend the programming team to your post.

    Cheers,
    E.J.

  • edited 6:43AM

    Hey guha,
    JASP installation is smooth in Debian based systems.
    Currently JASP installs without any problems on only some flavors (and versions) of arch Linux and Fedora derivatives.
    We will solve this as soon as possible.

    -Akash

  • edited 6:43AM

    Hi Kashyap,

    Both the packages, "jasp-desktop-git" and "jasp-rbundle" are present in AUR. For now, you can use this workaround -

    Manually install jasp-rbundle package from AUR (use pacman)
    Then, install jasp-desktop-git

    Make sure to set Qt chooser to use Qt 5.

    Let me know if you are still unable to install it.

  • edited April 2016

    Hi, Arch/Manjaro issue too.
    I have some problem with the "jasp-rbundle" package.
    Easy to find on the AUR, but errors appeared during compilation.
    It returns :
    ==> ERROR : arch should be an array
    ==> ERROR : depends should be an array

    The "jasp-desktop-git" package seems to be all right though.
    Solution ?

    EDIT :
    Just fixed it :
    You simply have to edit the PKGBUILD file, from
    arch='any'
    depends='r'
    to
    arch=('any')
    depends=('r')

Sign In or Register to comment.