Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

[open] Pygaze OpenSesame drift correct plugin issue

edited May 2016 in PyGaze

Hi there,

Using a fresh install of the most recent OpenSesame release on Windows. I can get the experiment running normally, and I can use all of the PyGaze plugins just fine....

except for the drift correct one! I've tried both dummy and advanced dummy modes, though I've not tested it with a real tracker connection.
I've tried digging round the source code but I can't work out the problem, so any help would be appreciated! Traceback is here:

[pastebin:fKygWnmA]

Comments

  • edited 7:11AM

    Hi,

    As far as I know, the drift correction module only works with an actual eye-tracker!

    Cheers,

    Josh

  • edited 7:11AM

    Ah, well that would explain it!

    Thanks Josh!

  • edited 7:11AM

    Hi guys,

    Drift correction should work in dummy mode as well; that is, drift-correction should be ignored, or simulated with the mouse (in advanced dummy mode).

    Have you by any chance inserted the pygaze_drift_correct item before the pygaze_init item? Initialization should always come first.

    Cheers!
    Sebastiaan

    There's much bigger issues in the world, I know. But I first have to take care of the world I know.
    cogsci.nl/smathot

  • edited 7:11AM

    Hi again,

    It was definitely after the init item. But it does seem to work with a tracker connected.

    Cheers

  • edited 7:11AM

    Could you maybe upload the experiment somewhere? That way I can take a look to see what's going on.

    There's much bigger issues in the world, I know. But I first have to take care of the world I know.
    cogsci.nl/smathot

  • edited 7:11AM

    Okay this is weird. I made an example here: http://www.filedropper.com/fdsgdfg

    The dc was after the init when I set it up. However after uploading and downloading, the file that opened had the dc before everything. I just repeated the same process and that didn't happen again.... but the error is still present. File attached.

  • Hi all, I am wondering if you guys were able to figure out what was going here? I am having the same problem, while the simple dummy works the advanced dummy mode doesn't. I tried switching the backends, on psychopy backend the mouse seems to work but my stimuli (video) is not displayed. On pygame backend the it runs fine on the simple dummy but it gets stuck on the drift when I try using the advanced dummy mode to simulate eye movements with mouse.

    cheers!
    Helio

Sign In or Register to comment.