Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

[solved] Problem using synth in 3.0.7-py2.7-win32-3

edited May 2016 in OpenSesame

Hi, we're trying to run an experiment (developed on a Mac) which uses the synth to play a tone. We get an error: The synth is not available, because numpy is missing.

It seems in fact as though numpy imports fine but an exception is raised by the following line in synth.py: from scipy import signal. Trying to debug this, we get

ImportError                               Traceback (most recent call last)
<ipython-input-3-c14ca79fb68c> in <module>()
----> 1 from scipy import signal

dist\scipy\signal\__init__.py in <module>()

ImportError: cannot import name sigtools

Searching the web leads me to think that we're missing a relocatable library for sigtools (sigtools.pyd is the only relevant-seeming file I can find in our installation).

That's where I get stuck, though (not a habitual Windows user): Can anyone suggest how we might go about trying to fix this?

Many thanks

--MC

Comments

  • edited 9:22AM

    Hi,

    For me the synth works fine, using 3.0.7-win32-3 on Windows 7 64 bit. You're using the official OpenSesame package, right? If so, this sounds like an incompatibility between the operating system and scipy. What is this computer's architecture (32 or 64 bit) and the exact version of Windows?

    Cheers,
    Sebastiaan

  • edited 9:22AM

    Hi,

    thanks! It's Windows 7 Enterprise, SP1 (32-bit).

  • edited 9:22AM

    My instinct tells me that it's the 32 bit architecture. Does the same experiment run fine on Windows 7 64 bit?

  • edited 9:22AM

    Not sure I have a machine free to check! Will hunt for one and get back to you. Thanks!

  • edited 9:22AM

    Hi, can confirm that everything works fine on a fresh 64-bit Win7 install. Problem, but not mystery, solved - thanks :)

  • Was this mystery ever solved? I'm running Windows 10 Enterprise (v. 1809) 64-bit and getting the same error message. I have another machine running an older version of Windows 10 (also 64 bit) and not getting the error.


    Thanks!

    Katie

Sign In or Register to comment.