Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

problem to run experiment on opensesame

Can someone help me to understand...
since yesterday i can't run experiment neither other experiment like beginner tutorial for open sesame.
i have always the same error :

Unexpected error

exception message: [Errno 2] No such file or directory
time: Sun Dec 4 15:47:43 2016
exception type: OSError



  • Hi all, I have a similar problem. Apparently I made a typo in a multi-item ready form and I forgot to close a statement with quotation mark. The problem is that I cannot open the experiment anymore! I get the following error:

    Failed to open the file for the following reason:
    Failed to parse line "my statement"". Is there a closing quotation missing?

    item-stack: ``
    exception message: No closing quotation
    time: Mon Dec 5 15:30:38 2016
    exception type: ValueError

    The thing is, how can I fix the typo if I cannot open the experiment anymore? I really need to work on this file, did it somehow get corrupted and won't open anymore? I am using mac.

    Than you in advance!


  • Hi Veronica,

    You can manually edit the experiment script in a text editor to fix the issue, and the re-open it in OpenSesame. If you attach the file to this post we could take a look. So that will be fine.

    The important question, however, is how this happened in the first place. Do you have an idea what happened? Or even better: do you know how to reproduce it?


  • @oriane_g26 Are you having the issue described here?

    If so, let's continue the discussion there.

  • Hi Sebastian,

    I have no idea how that happened and how to reproduce it, I know that OP crashes from time to time on my machine (Mac) but actually all experiments before have opened normally after crashing. I have ow tried to open the experiment on a text editor but all i can see are weird symbols (flóÏDv). I attach the file to this post and I hope you can help me!

  • Hi
    I've try to delete and install again, but the problem remain...

  • @Veronica I attached the fixed version. Essentially you can extract the file pool and script with a tool like 7zip, and then edit the script, as described here:

    The error has something to do with the type of line endings used on Mac OS. I'm going to look into it.

  • Thank you Sebastian!

  • edited December 2016

    @Veronica Do you sometimes copy-paste text into OpenSesame? For example that you prepare some text in a text editor, and then paste it into OpenSesame?

    @oriane_g26 Please post a note in the other discussion with some more details, including your operating system, the exact version of OpenSesame, and which runner is selected (you can see this under Tools → Preferences).

  • Yes I do, might that be a problem?

  • Yes I do, might that be a problem?

    It's an explanation, yes. Line breaks are encoded differently on different platforms. OpenSesame should compensate for this through a conversion, but this conversion appears to be bypassed when pasting directly into a text field. That's a bug of course, but easy to work around for now: Don't copy past multiline text into OpenSesame on your Mac OS system.

  • Alright, then. Thank you very much!

  • i've found where was the problem.
    It was external runner mode which was selected and i've changed to mutliprocess as suggested in the other discussion, and apparently it works !

    Thanks for your help !

  • Hi @sebastiaan

    I have done copy-paste into a table with several columns at once, yes. So I guess that may be the issue. However, I'm not sure how to extract the script from the .osexp file since 7zip only seems to be for Windows! Is there an other good option?

    Thank you!

  • I have done copy-paste into a table with several columns at once, yes. So I guess that may be the issue. However, I'm not sure how to extract the script from the .osexp file since 7zip only seems to be for Windows! Is there an other good option?

    If you rename the experiment file to something.tar.gz, Mac OS will probably recognize the file format and allow you to extract the contents. (As explained here, this is only necessary if there are files in the file pool; otherwise you can directly open the experiment file in a text editor.) In the script, you will find something like:

    set somevariable "one line
    another line
    a third line"

    This is syntactically invalid OpenSesame script, and should be changed to:

    one line
    another line
    a third line
  • @Tina would you mind upgrading QProgEdit (the text editor component of OpenSesame) and test if you can now safely copy-paste multiline text?

    You can upgrade by running the following in the debug window:

    import pip
    pip.main(['install', 'python-qprogedit', '--upgrade'])

    You can check if the upgrade was successful by verifying whether QProgEdit is now 4.0.7 (under Tools → System information)

  • edited January 2017

    Hey @sebastiaan
    Sorry for the late response. Changing the experiment file and moving up a bunch of quotation marks seemed to work, I can open the experiment again. Thank you for that!

    I upgraded QProgEdit to 4.0.7 and tried to copy-paste a few rows and columns from Excel but the last column still drops to the next line for the last ". Here is a bit of the script:

    setcycle 0 empty_column "101.jpg"
    setcycle 0 new_column_1 "102.jpg"
    setcycle 0 new_column_2 10
    setcycle 0 new_column_3 1
    setcycle 0 new_column_4 0
    setcycle 0 new_column_5 "c
    setcycle 1 empty_column "111.jpg"
    setcycle 1 new_column_1 "112.jpg"
    setcycle 1 new_column_2 11
    setcycle 1 new_column_3 0
    setcycle 1 new_column_4 1
    setcycle 1 new_column_5 "m
  • @Tina

    Thanks for testing this. It seems that you're running into the same type of issue but in a different module: python-qdatamatrix, which is used for the loop table. So let's update that one as well:

    import pip
    pip.main(['install', 'python-qdatamatrix', '--upgrade'])

    Once you've done that, restart OpenSesame and check the version of qdatamatrix under System Information. It should be 0.1.10.

    Does that solve the issue? That is, can you copy-paste stuff into the loop table and the editor components without getting corrupted OpenSesame script?


  • edited January 2017


    This time around when I try to copy-paste more than one column, everything just ends up in multiple columns along the first row. On top of the script being corrupted. If I copy-paste one column only, everything gets entered into just the one box. Below was originally one column with 10 rows in excel.

    set source_file ""
    set source table
    set repeat 1
    set order random
    set description "Repeatedly runs another item"
    set cycles 3
    set continuous no
    set break_if_on_first yes
    set break_if never
    setcycle 0 empty_column "2
    setcycle 1 empty_column ""
    setcycle 2 empty_column ""
    run ""

    and below was 3 columns with 3 rows in excel.

    setcycle 0 empty_column "t021.jpg"
    setcycle 0 new_column_1 2.0
    setcycle 0 new_column_2 "0
    setcycle 0 new_column_3 2.0
    setcycle 0 new_column_4 "1
    setcycle 0 new_column_5 5.0
    setcycle 0 new_column_6 1.0
    run ""

    Also, I can no longer remove rows or columns without getting this error message

    Traceback (most recent call last):
      File "/Applications/", line 89, in activate
      File "/Applications/", line 65, in inner
        retval = fnc(self, *args, **kwdict)
      File "/Applications/", line 205, in _remove_rows
      File "/Applications/", line 488, in __delitem__
        _slice = self[value] ^ self
      File "/Applications/", line 513, in __getitem__
        return self._slice(key)
      File "/Applications/", line 182, in _slice
        _rowid = self._rowid[key]
      File "/Applications/", line 69, in __getitem__
        return self._l[item]
    TypeError: list indices must be integers, not tuple
  • Hi Tina,

    Thanks again. I guess we need to get a developer with a Mac on top of this.

    @Daniel ? I know you have plenty on your plate, but could you take a look at this? In a nutshell, both QProgEdit (editor component) and QDataMatrix (loop table) have problems with pasting multiline text on Mac OS.


  • No problem! Let me know if you solve it so that I can start copy-pasting :-)

  • Sure! I tend to easier keep track of the things on my plate by using Github's issue tracker. With the forum this is a bit harder. Could you add this issue to the relevant Github repositories and mention or assign me to them?

  • Hello, I'm a new user of Open Sesame. I sketched a really basic experiment with only one item and I wanted to run it so I can test if it runs smoothly on my computer. When I hit the Run in full screen or run in window button I get the error message that the GetNumaNodeProcessorMaskEx was not found in library KERNEL32.dll. How can I combat this problem ? By the way, I have Windows Vista on my laptop and a 32 bit system.

    Thanks in advance for any help!

  • Hi,

    I've never encountered this error message before. I imagine that it's an incompatibility between Windows Vista and some Python library.

    If possible, I would update the operating system, or find a different laptop that runs a more recent version of Windows. However, if that's not possible, perhaps you could check if you get the same error message when you try a different backend (such as legacy)?



Sign In or Register to comment.