Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

Screen stretched with legacy backend

I have chosen to use the legacy backend, because I am using forms in my experiment and this is the only backend that allows them to work quickly enough. However, when I use legacy, the instructions, forms and sketchpad images all become very stretched on the screen. I'm guessing that this is because I am using a wide-screen monitor, but the other backends appear to display the experiment in a nice standard layout (not stretched) regardless of the monitor I'm using.
How can I adjust the experiment so that the screen size is a standard size on all monitors? I tried adjusting the resolution in the New Experiment tab with the legacy backend, but this cuts off the sides of the sketch pad items, and the experiment does not look as good as it does using the other backends.

This is a screenshot of what it looks like using xpyriment (how I want it to look - looks the same on different monitors).

This is a screenshot of what it looks like using legacy (it looks even more stretched on my widescreen monitor).

This is a screenshot of what it looks like using legacy but changing the resolution to try to make it fit (cuts of the canvas image and still doesn't look as good as with xpyriment).



  • balbal
    edited December 2016

    Oops, those images appeared in the wrong order! So the bottom one is how it looks using xpyriment and how I want it to look with legacy. The top one is how it looks with legacy (stretched). The middle one is what is looks like with legacy but with the resolution changed to it cuts off the sides of the canvas image.

  • Hi,

    The legacy backend changes the resolution of the monitor. The default resolution is 1024 × 768, which looks pretty awful and stretched on a large widescreen monitor. In contrast, the psycho and xpyriment backends don't change the resolution, but create a kind of virtual display in the center of screen.

    So if you use the legacy backend, it's best to change the resolution to match your monitor's native resolution. Does that make sense?


  • That worked, thanks! I wasn't changing the resolution to the correct one for my monitor's native resolution.

    Cheers :)

  • Hi,

    I have an experiment I need to display on two screens with different resolutions (1920x1080 and 1366x768). I need those two screens because the experiment is conducted in two different locations with different equipments.

    I want to set the resolution to 1366x768 (based on the lower resolution of screen I can get), but text and images are stretched when I launch the experiment on the 1920x1080 screen (black borders are added at the top and bottom of the screen).

    Is it possible to avoid this while keeping a 1366x768 resolution on the 1920x1080 screen ?

    I am using the legacy backend and noticed that this issue did not occur with psycho. Yet, psycho caused displaying issues (screen going black between trials notably), which is why I think I should stay with legacy.

    Thanks in advance for your help.


  • HI @Jessica Bourgin ,

    The resolution indeed has different effects depending on the backend and operating system. Specifically, the legacy backend really changes the resolution, whereas the other backends leave the display resolution as it is and present the stimuli in (what you could think of as) a virtual window in the center of the screen.

    Would be it be an option to simply create two versions of the experiment that only differ in the resolution? That seems like the easiest way to me.



    PS. I do not generally recommend creating different versions of an experiment, because you run the risk of unintended differences. But in this case it might nevertheless be the most pragmatic solution.

  • Hi @sebastiaan,

    Thanks a lot for your answer. I considered this option but since the ratio width/height is similar for the two screens, I wanted to avoid creating two versions of the experiment.

    I found an alternative : I changed the display settings of my graphic card to fullscreen (the default was "adapt screen size").

    This way, the experiment is correctly displayed (without black borders) when I change the resolution from 1920x1080 to 1366x768.



  • Good to hear you found a solution!

Sign In or Register to comment.