Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

sound start recording always overwrites

Hello,

I'm using the sound_start_recording plugin embedded in a loop to record short audio input (~2-5 seconds). Even though I've selected it to create new media file each iteration it's only ever recording the last run of the loop. Any thoughts?

Thank you!

Comments

  • Hi Mikaelr. Just to be sure: Have you also include the sound_stop_recording item at the end of the trial?

  • Hi Daniel. Yes, that's correct.

  • A couple quick additional questions:
    1) I define an output folder/file name but that didn't help...but I see that the statement is "if file exists...append suffix to filename" - do I need to/can I define what the suffix is somewhere?
    2) Is there a way to write the start/stop record audio to the EDF msg log the same as the start_trial and stop_trial status messages for pygaze (the only variables I see are 'time_sound_start_recording' and 'time_sound_end_recoding')?

    Thanks again for your help!

  • That sounds like a bug then. I'm just surprised you're the first to ever report this behavior, as the plugin has been around for a while (and is in dire need of an update), so I assume someone should have bumped into this thing before.

    1) No the suffix should be appended automatically.
    2) You'd need to look into the Pygaze docs for this. There should be a function called, eyetracker.log() with which you can send messages to be saved in the EDF file.

    Could you take a screenshot of your overview panel (where the structure of the experiment is shown) of the experiment you experience this bug with?

  • Just a couple notes: I was originally using ver .12, I updated to ver .15 with no change. I also tried all the different backends to no effect.

  • edited May 2017

    I am encountering the same issue, that I cannot save multiple sound files. They always overwrite the previous version. I tried using .Mp3, and .wav files. I don't get an error message either. It simply overwrites it.
    Any updates on the fixes for this?

    Just to specify, I'm running the latest version of Opensesame.

  • I'm having the same problem...

    Aso, the problem has been mentioned again by rampriya darshini in January this year (http://forum.cogsci.nl/index.php?p=/discussion/2686/how-can-i-collect-audio-response-in-open-sesame)

    Running the latest version as well (windows)

  • Hi

    I am also having this problem with version the latest version of OpenSesame.

    I used the "Append to suffix filename" option and I still get the recording only for the last iteration (i.e., the last word in my word naming task).

    I can record the entire loop by placing the recording option before the loop, but because I am interested in calculating voice onset time, and Sebastiaan suggested not relying exclusively on the voice onset code, I am still interested in recording each iteration in the loop separately. Has anyone found a solution?

    Thanks in advance for your assistance.

  • Hi,

    I don't know how to properly solve the problem with the plugin, but what you could do is following. After a trial, once you saved the most recent file, you can use the python os package to rename the file to something else. The syntax is rather easy:

    import os
    os.rename('a.txt', 'b.kml')
    

    You just have to define a unique filename for your recording.

    Does this make sense?

    Eduard

Sign In or Register to comment.