Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

can't get practice trials to work

Hi all,

I'm having trouble getting my experiment to run a practice session where it only goes through 5 trials before moving on to the experiment proper. I tried to follow the discussion here. but I still get the error:

The variable 'count_trial_sequence' does not exist. Tip: Use the variable inspector (Ctrl+I) to see all variables.

When I check the inspector, I see the count_trial_sequence variable. I tried adding a script at the beginning (before the experiment sequence) that ran the following:

count_trial_sequence = 0

But that didn't work either. Here is a link to my experiment if it might help answering my question..

Thanks so much!



  • Hi Bryn,

    Everything is setup as it should, except that you should uncheck the checkbox "Evaluate on first cycle". What happens is that OpenSesame checks whether the break--if statement is true before the sequence has been created, therefore the variable does indeed not exist and it gives you the error.

    Let me know if it works!


    ps. Did you manage to get the Android experiment running?

  • Hi Laurent!

    This is very helpful, thanks! I was able to get it running, as long as I save the experiment on the device storage. Not ideal, but it will work for now.

    As always, I greatly appreciate your help!


  • I should note that your suggestion fixed my problem with the practice trials. Thank you!

  • Hi all

    it seems I am running into the exact same problem (the variable is considered non-existent, which is true before the sequence has begun but should then turn up to exist later), except I did uncheck the "evaluate on first cycle" checkbox.

    Any suggestion?


  • Hi Thomas,

    Can you share your experiment? Did you make sure that you have no typo when using the variable name? Not sure whether it is relevant, but it is also possible that you have to put the relevant code in the prepare phase, not the run phase (without more information on your setup that is a little hard to say)


Sign In or Register to comment.