Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

black screen when I "Press Enter to show camera image" with eyelink on ubuntu

Hello! I am running OpenSesame 3.1.7b1 on Ubuntu (I have tried with 16.04 and 17.04) and I am trying to connect to my EyeLink 1000 plus using the eyelink display software. I am confident the eyelink stuff is installed correctly because I can connect to the tracker, see video from the camera, calibrate, etc. using gcwindow (both the standalone and from within python).

When I try to run an OpenSesame experiment with pygaze using the Eyelink tracker I get the usual startup menu (with calibrate, validate, etc.). If I press enter to view the camera, though, the screen goes black and won't accept any more input. I can only get out by killing the processes from the terminal.

I tried launching opensesame from the terminal and got the following errors from QT:

QXcbConnection: XCB error: 128 (Unknown), sequence: 1554, resource id: 218, major code: 130 (Unknown), minor code: 2
QXcbConnection: XCB error: 13 (BadGC), sequence: 1555, resource id: 218, major code: 60 (FreeGC), minor code: 0
QXcbConnection: XCB error: 3 (BadWindow), sequence: 1556, resource id: 60817571, major code: 4 (DestroyWindow), minor code: 0

Has anyone else had this problem? Is there anything else I should be trying or looking at to figure out how to fix this?

Many thanks for any help.


  • Hi,

    A few questions:

    • Does this happen with all backends? If not, which backends are affected?
    • Can you run normal experiments, i.e. those that don't connect to the EyeLink?


    There's much bigger issues in the world, I know. But I first have to take care of the world I know.

  • Thanks so much for the quick reply, sebastiaan.

    Yes, it seems to happen regardless of backend. And yes, I'm able to run other OpenSesame experiments. The pygaze ones even sort of work as long as I don't try to view the camera.

  • Hmmm, I haven't heard about this issue before. (But then again not many people use the EyeLink on Ubuntu. I used to do that myself, but not anymore.=)

    Do you see error messages or useful output in the debug window?

    There's much bigger issues in the world, I know. But I first have to take care of the world I know.

  • No, I am afraid there is nothing added to the debug window.

    I've just installed Windows 7 on a second drive in this machine and verified that OpenSesame + Eyelink works there. This is a suitable work-around for now so I'm not stuck anymore, but I'm happy to help debug and investigate this Ubuntu problem in any way I can.

  • I wanted to follow up on this and say that I was wrong. OpenSesame + Eyelink will run on Windows and I can collect data, but I can't get the eyelink camera view to show up on the display computer during setup and calibration. No errors in the debug window that I've seen.

  • Hmmm. Well, if you have the same issue on Windows, then one thing that comes to mind is that you're running outdated EyeLink software. Could that be it? You can download the latest EyeLink display software from the SR Research forums.

    There's much bigger issues in the world, I know. But I first have to take care of the world I know.

  • bah, sorry, whatever was happening on windows was temporary and was fixed by a reboot. This is embarrassing.

Sign In or Register to comment.