Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

Eyetribe, pygaze (opensesame) and video presentation

Hello all!

I'm using Opensesame to run an experimento in which participants view a short video and after they must answer a scale regarding the video.

I'm using Pygaze and Eyetribe to try and collect gaze data. If the Eyetracker is not calibrated, the videos play just fine. However, if the eyetracker is calibrated, the videos don't work. It only appears a gray screen and nothing more.

Anyone can advise as to what might be happening?

Thanks in advance!




  • edited June 2018

    Hi Roberto,

    Would you mind specifying what you mean by "If the Eyetracker is not calibrated"? Do you mean when you use dummy mode, or do you mean when you don't calibrate the tracker but it is active?

    In addition, an exact error message would be very helpful, if you have one. And a more precise and elaborate description of the problem.


  • Hi Edwin!

    Thank you for your reply!

    Sorry for not being clear! Yes, by not calibrated I meant dummy mode.

    There is no error message. The experiment actually proceeds normally, the problem is that instead of the video playing I get a silver screen during the length of the video.

    The experiment is a short video (no more than 1:30 min) followed by two questions regarding the emotional valence perceived in the video. The videos appear normally if it is in dummy mode. But if I use it in the eyetracking mode, then the videos do not show.

    I don't know if it might be a codec issue or if it is something to do with the Eyetribe server. I know that the Eyetribe server can sometimes impair the use of the wi-fi.

    I don't know if it I made my problem more clear, if not, please let me know and I'll try to upload some screenshots.

    Thanks again

  • Hi Roberto,

    That is very weird; I've never seen this particular issue. What back-end are you using, and how are you presenting the videos? What happens if you change back-ends, or the way you play your video?


  • Hi Edwin,

    I tried with psychopy and legacy. I'm presenting them via media player mpy. It works fine in one of my laptops but in others it does not.

    In my laptop I'm running OpenSesame 3.1. The others are running OpenSesame 3.2. Can it be a version issue?

    If I change back ends the problem continues. It is just a black or grey screen with the original audio from the video.

  • Hi Roberto,

    It might well be! Could also be an issue with your laptop's OS. To be honest, I have no clue, as I didn't develop the media_player_mpy.

    @sebastiaan and @Daniel should know more!

    Good luck!

  • Hi Roberto,
    Sorry for my slow response. I have never heard of or seen this problem before. My knowledge of pygaze is too limited to know what is does for media_player_mpy to possibly fail.
    Since it works for you on one of your laptops and not on the other, it gives me the impression that this is a video driver issue of laptop on which it doesn't work (at least, a grey screen is a common sign of driver/hardware decoding problems). You are also mentioning that you are using different versions of OpenSesame. Are you experiencing this problem with OS 3.1 or 3.2? If the former, have you tried upgrading to version 3.2? It does have newer versions of all dependency packages, so it might be that this problem originated, and has been fixed in one of the dependencies.

Sign In or Register to comment.