Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

Logging in to the OSF

Hi everyone,

I don't see the "log-in button in the main toolbar" for logging in to the OSF. I am on ubuntu. I have checked on a mac and it works well.

Any ideas ?

Thanks +++

Brice

Comments

  • Hi Brice,

    This is a separate extension, although it is included by default with the Windows and Mac OS. You can install it with:

    pip install opensesame-extension-osf
    

    Cheers!
    Sebastiaan

    There's much bigger issues in the world, I know. But I first have to take care of the world I know.
    cogsci.nl/smathot

  • Hi Sebastiaan,

    Thank you very much for your quick response. Sorry, I should have mentioned that I already tried to install the extension but it changes nothing in opensesame. I can't see the log-in button even after installing the extension.

    Thanks again +++
    Cheers !

    Brice

  • Hi Brice,

    Do you have multiple Python environments? If so, you may have installed the extension into a different Python environment from the one that OpenSesame is using.

    And have you checked whether the extension is enabled (Menu → Tools → Plug-in and extension manager)?

    Cheers!
    Sebastiaan

    There's much bigger issues in the world, I know. But I first have to take care of the world I know.
    cogsci.nl/smathot

  • Hi Sebastiaan,

    Thank you so much for your help. I also thought it was a problem of Python versions but I was not sure and I could not find how to deal with it. I checked again after your message and indeed, you were right, this is THE problem.

    python -V gives me
    Python 3.6.3 :: Anaconda custom (64-bit) in the terminal

    And OpenSesame is on Python 2.7.15 so I had to install

    pip2 install opensesame-extension-osf in the terminal instead of
    pip install opensesame-extension-osf

    Thanks again +++
    Cheers!

    Brice

Sign In or Register to comment.