Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

plug in not working

Hello all,

Plodding on with learning opensesame (as a researcher who generally doesn't go near a lab this is interesting). Wasn't sure if to put this here (as it is about plug-in) or in mousetrap chat. I am trying to install this but not getting far.

What am I doing wrong? I tried two things:

1 Installed the folder into a variety of places (this became fairly desperate) and then cut and pasted this text into the debug screen.

pip.main(['install', 'opensesame-plugin-mousetrap'])

NB I have windows 10 and do not have the pathway [opensesame folder]\plugins; however, I do have share/plugins AND share/extensions = i put the folders in each of these!

2.I finally worked out I could search for mousetrap in the "Python package manager" which shows it wasn't installed, clicking on install sent the following failure message: I tried this in administrator mode. I also deleted all the files I had previously copied to the opensesame folders and ran it again. I am now at a total loss!

Python 2.7.13

* Type "help()", "copyright()", "credits()" or "license()" for more information.

* Use the "print([msg])" function in inline_script items to print to this debug window.

* Inspect inline_script variables when an experiment is finished.

Collecting mousetrap

Collecting python-xlib (from mousetrap)

 Using cached

Requirement already satisfied: six>=1.10.0 in c:\program files (x86)\opensesame\lib\site-packages (from python-xlib->mousetrap)

Installing collected packages: python-xlib, mousetrap


  • Hi there,

    to install the mousetrap plugins, you can follow installation instructions in the mousetrap-os documentation:

    If you are using OpenSesame 3.2 or later, make sure to install the development version. In short, you just need to run OpenSesame in admin mode and paste the following command into the debug window:

    import pip
    pip.main(['install', ''])

    Afterwards, you need to restart OpenSesame and the mousetrap plugins should be there.

    Please let me know if this does not work for you, and if so, please specify which OpenSesame version you are using.



Sign In or Register to comment.