Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

failing to install mousetrap pluggins

Hello, I've had issues with the installation. I'm currently working on a Mac and here's what happens:

I run the command in the debug window and this is what appears:

import pip

pip.main(['install', 'opensesame-plugin-mousetrap'])

AttributeErrorTraceback (most recent call last)

<ipython-input-1-ed03669cb547> in <module>()

   1 import pip

----> 2 pip.main(['install', 'opensesame-plugin-mousetrap'])

AttributeError: 'module' object has no attribute 'main'

I also tried to look for it on the python package manager but when I try to open this, the following message appears: "Extension package_manager misbehaved on activate (see debug window for stack trace)".

What can I do?


  • edited September 2019

    Which pip version do you have? I believe that the pip.main() method was removed from v10 onwards.

  • Hi there,

    I think the comment by @cesco is correct. The problem is that OpenSesame for Mac OS and for Windows seem to be using different versions of the pip library. We already discussed this issue in the following thread:

    In addition, you should install the most recent development version of the mousetrap-os plugin.

    In sum, this means you need to change the installation command under Mac OS to:

    import pip._internal
    pip._internal.main(['install', ''])



  • Thank you @cesco and @Pascal! it's now successfully installed!

Sign In or Register to comment.