Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

Shadowing task ; How to present multiple audio stimuli

Hi everyone,

I'm very new at Opensesame. I'm trying to build an experiment where the participant is presented with a sound and the person has to repeat the words into a microphone (recorded speech). Right now i'm not at the recording part yet. I don't know how to present more than one sound.

I created a practice_loop and block_sequence with the list of all the .wav stimuli in the table under Stimulus , in block sequence i dragged a sampler. But i can only manage to play one sound from my pool but i want to play all the 20 sounds from my file pool. How can I do this?

Sorry if it's such a newbie question!

Comments

  • Hi,


    Is this question different from the other one you have asked?

    Are you planning to play the 20 sounds simultaneously? In this case, you need multiple samplers, whose duration field has a value in it that is shorter than the actual sounds (otherwise the would play in sequence).

    Eduard

    Ps. (Maybe it is better to discuss these problems in the same thread and not multiple ones)

  • edited September 19

    Hi Eduard!

    It appears I've solved my problem, I wanted to play the sounds one after the other which I managed by creating a sequence, I just had a syntax error, I forgot to put brakets around [stimulus] for the sampler audio file. It now works! I do have another question if you don't mind!

    I would like to record the participants' speech after each auditory stimuli, would you know how I can do this?

    Thank you !

    (by other threads you mean the questions I ask underneath old threads ? If that's the case, i'll focus everything here, sorry!)

  • Hi again! I fixed my issue with the sound_recorder plug-in! Used the v016 that has been debugged from someone else on this forum (thank you so much for that).

    I then was able to make it work but i would only be able to have the last iteration recorded! If you encountered the same problem as me, here's how i put my settings to make it work:


    set samplerate 44100

    set recording Yes

    set output_file "recordings/subject_[subject_nr]/trial-[count_block_sequence]"

    set file_exists_action "Append suffix to filename"

    set compression "None (wav)"

    set channels Mono


    I hope it helps someone else!

    Best,

    Nora

    Thanked by 1eduard
Sign In or Register to comment.