Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

Accents not allowed in form_text_input items

Hi all,

I have an Open Sesame experiment in which at the end of a trial, experimental subjects have to type in a word. The item form_text_input appears not to allow experimental subjects to properly type in accented words such as, e.g., the Spanish word [nación]. When typing it, it shows up in the form as [naci'ón] instead of [nación]. In other words, when pressing the accute accent key [´] before pressing the actual key for the vowel [o], Open Sesame inserts a straight accent ['] and then the accented word [ó], which results in the incorrect form ['ó].

This is very confusing for the experimental subject, who tries (in vain) to type in a simple accented word [nación] but ends up with something strange [naci'ón].

I have checked the forum but found no solutions to this. Any tips, please?

Thanks.

Comments

  • Hi,


    I just tried it and, indeed, if the Keyboard layout/language is english it doesn't work. However, I switched it to German and there I could combine ^ with a to get â in the text input field. So try changing the keyboard layout of the system.

    Does that make sense?

    Eduard

  • Thanks, Eduard. The thing is that the system (Windows) keyboard has been always set to Spanish (ESP), and it doesn't work.

    I have also changed the Open Seame language to Spanish (Tools>Preferences>Appearance>Language>es_ES), but it does not work either. I keep on getting the same error when typing: I get [naci'ón] instead of [nación].

    This is very confusing for the experimental subjects.

    Does anyone have any tips for this problem? Thanks.

    Cristóbal

Sign In or Register to comment.