Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

Python Crashing

Just wanted to report that during quick runs of my experiment in opensesame, it seems to only get through a few trials before python crashes. It's not always at the same time, so I'm not certain what's causing it, but I haven't been able to run through the whole thing without crashing.

Comments

  • Hi,

    Thanks for reporting this. We're aware that this happens sometimes, and it's pretty awful when it does. It's always due to a bug somewhere in the underlying libraries, and therefore really difficult to debug. As a workaround, you could try a different bekend, or the Python 3 version of OpenSesame.

    Cheers!

    Sebastiaan

  • If I'm using version 3.2.8 already, is there anything that seems to help with the crashing? I'm running on a mac OS with python 3.7 and have a few experiments being coded in opensesame, none of which seem to proceed past the first trial without python crashing. Would older versions of both be more reliable?

  • All the different software versions are a bit confusing, I understand that! ;-) but OpenSesame 3.2.8 can run with Python 2 or 3. So the versions of OpenSesame and Python are independent of each other. Also, OpenSesame comes with its own Python interpreter, so it doesn't matter what the default Python version on your Mac is (it won't be used).

    That being said, there is currently no Python 3-based package for Mac OS. So yes, trying a slightly older version of OpenSesame might help. What version of Mac OS are you running exactly?

    (Ping @Daniel )

  • Are you running OpenSesame from source? I also have had mixed experiences running OpenSesame with python 3 on a mac. It would also help if you could provide the error message that you see after OpenSesame has crashed.

    • Sorry for the delay, I'm running MacOS Catalina 10.15.1 and have it downloaded to my computer's system as an application. The error I get each time is after the response and "Python seems to have crashed. This should not happen. If Python crashes often, please report it on the OpenSesame forum." The specific file I'm using is from somebody else's experiment, and their program has been running subjects, so I'm not sure why this keeps crashing my python.


  • If you have downloaded and use the OS application, then you are internally using Python 2 (which is packaged with OS). To be honest, I've more often seen the message "Python seems to have crashed. This should not happen. If Python crashes often, please report it on the OpenSesame forum." even when it is a crash that OpenSesmae should recognize and handle itself. I don't know yet what the reason is, but if you change the runner in setting from 'multiprocess' to 'in-process', you should see the proper error message. Don't forget to switch back to multiprocessing afterwards though, as it works more stable in general.

  • hi Sebastian, how do I configure my 3.2.8 version to work with python 3? thank you

  • Hi bluelook,

    You have to download the Python-3-based package, which you can find here:

    Cheers!

    Sebastiaan

  • edited December 2019

    oh wow! i have spent so many hours to create what pandas already have, in my python 2 version, i should have downloaded the right version.. i feel embarrassed 😅

Sign In or Register to comment.