Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

Loops in beginner tutorial don't run

I've created an OpenSesame experiment of the beginner tutorial at

When I run the experiment, the instructions, end-of-practice and end-of-experiment texts display correctly but the practice and experimental loops never execute. The log file is empty, but this is probably because the loops don't execute. As far as I can tell, my experiment is the same as that shown in the tutorial. Any suggestions on why the loops aren't running?

I'm on Windows 10 using OpenSesame 3.2.8


Greg Reese


  • Hi Greg,

    there must at least be one line in a loop table, even if no values are defined. So, if you click in the first cell of the loop table, one row should be added and then the loops will run.

    Does that make sense?


  • Hi Eduard,

    Thanks for your suggestion but I don't think I understand it. The practice loop currently looks like this:

    The cell with "empty_column" is something that OpenSesame put into the table. I clicked in that cell but nothing happened. I also clicked on the cell beneath it and it turned the background light gray (difficult to see in the above screen shot). However, nothing changed when I ran the experiment - I still get only the text forms and the loops don't execute.

    Am I following your instructions correctly?


    Greg Reese

  • Aha! Got it! I looked at the tutorial screen cast and it showed the cell beneath the "empty_column" cell with a "1" in it. When I made that change the experiment worked.

    Is there a place to report errors or request changes in the tutorials?


    Greg Reese

  • Well, the wish list could be such a place. But if you feel adventurous, you can also implement the change yourself. The documentation is on Github and suggestions/editions are always welcome.


Sign In or Register to comment.