Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

installing mouse trap plugging 2.0.0

Hi,

I tried to installing older version of mouse trap and it failed and than i attempted to install mousetrap-os 2.0.0 from the github page, and the read me file is not accessible. how to install it?

Comments

  • Hi,

    we provide the installation instructions for the mousetrap plugin on the following page:

    https://github.com/PascalKieslich/mousetrap-os#installation

    Does this help?

    If it does not work: which version of OpenSesame are you using? And on which operating system?

    Best,

    Pascal

  • @Pascal i'm using opensesame 3.2.8 on windows 10. I tried to run this command in the debug window

    import pip
    pip.main(['install', 'opensesame-plugin-mousetrap'])
    

    I'm getting the below error,

    WindowsError: [Error 5] Access is denied: 'C:\\Program Files (x86)\\OpenSesame\\Lib\\site-packages\\opensesame_plugin_mousetrap-2.0.0.dist-info'

    You are using pip version 9.0.1, however version 20.0.2 is available.

    You should consider upgrading via the 'python -m pip install --upgrade pip' command.

    How exactly do i upgrade it?

  • Hi,

    you do not need to upgrade pip. You are experiencing a common issue (on Windows) which we have described in the installation instructions:

    If the installation fails due to missing write access, you may have to run OpenSesame with administrator privileges for the installation (on Windows, right-click the OpenSesame program icon and select Run as Administrator).

    Best

    Pascal

  • Thanks. it is installed now. But how do i access the plug in, i couldn't add it in the experiment sequence.

  • Have you restarted OpenSesame after the installation? The plugins should be available from the item toolbar afterwards - potentially you need to click on the arrows at the bottom of the item toolbar to display additional items including the mousetrap plugins if they are not visible by default.

Sign In or Register to comment.