Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

[open] Error: Source and destination surfaces need the same format. ????

edited March 2014 in OpenSesame

Hello everyone,

We tried to run our experiment on another computer than we were used to. We get this error: Source and destination surfaces need the same format.

We already tried to adjust the pixellevels, but this didn't work. When we run the experiment, it shows the instructions but when the actual task should begin, it stops and shows the error.

The computer is from the brand "Eizo" with a screen from " FlexScan S1932"

Please help!!!

Comments

  • edited 3:24PM

    Hi,

    Could you post the full error message, which you can find in the debug window? Please also include the relevant script, if the error results from an inline_script, and information about the operating system and back-end that you're using.

    Cheers!
    Sebastiaan

    There's much bigger issues in the world, I know. But I first have to take care of the world I know.
    cogsci.nl/smathot

  • edited March 2014

    This is the message displayed in the debug window:

    Python 2.6.1
    Type "help()", "copyright()", "credits()" or "license()" for more information.
    Type "modules()" for details about installed modules and version information.
    Use the "print [msg]" statement in inline_script items to print to this debug window.
    >>> 
    openexp.sampler._legacy.init_sound(): sampling freq = 48000, buffer size = 512
    openexp._canvas.legacy.init_display(): enabling hardware surface
    openexp._canvas.legacy.init_display(): enabling double buffering
    openexp._canvas.legacy.init_display(): video mode ok
    experiment.init_log(): using 'F:/defaultlog.csv' as logfile (ascii)
    experiment.run(): experiment started at Mon Mar 31 14:19:15 2014
    Traceback (most recent call last):
      File "G:\Programmatuur\opensesameportable-0.26-pre6-1-win32\opensesame-0.26\libqtopensesame\qtopensesame.py", line 1647, in run_experiment
      File "F:\opensesameportable-0.26-4\opensesame-0.26\libopensesame\experiment.py", line 258, in run
        self.items[self.start].run()
      File "F:\opensesameportable-0.26-4\opensesame-0.26\libopensesame\sequence.py", line 59, in run
        self.experiment.items[item].run()
      File "F:\opensesameportable-0.26-4\opensesame-0.26\libopensesame\loop.py", line 152, in run
        if _item.prepare():
      File "F:\opensesameportable-0.26-4\opensesame-0.26\libopensesame\sequence.py", line 119, in prepare
        if not self.experiment.items[_item].prepare():
      File "F:\opensesameportable-0.26-4\opensesame-0.26\libopensesame\sketchpad.py", line 184, in prepare
        self.canvas.image(self.experiment.get_file(_item["file"]), _item["center"] == 1, _item["x"], _item["y"], _item["scale"])
      File "F:\opensesameportable-0.26-4\opensesame-0.26\openexp\_canvas\legacy.py", line 572, in image
        int(surface.get_height()*scale)))
    ValueError: Source and destination surfaces need the same format.
    >>> 
    

    We are using an inline script but I don't know if thats the problem, however, this is the inline script were using:

    # we will need to import the library that
    # we will use to play the sound
    import pygame
    
    # first, we check if it is initialized; if it is
    # not, we initialize it
    if not pygame.mixer.get_init():
        pygame.mixer.init()
    
    # next, we will need to specify the sound
    # file (NOTE: this has to be added to your
    # file pool!
    sound_name = "5-0.wav" # change to your own filename
    sound_path = exp.get_file(sound_name)
    
    # now we initialize the sound; this means
    # we prepare it so that it can be played
    exp.sound = pygame.mixer.Sound(sound_path)
    
    # finally, play the sound! (the -1 indicates
    # that it should play infinitely)
    exp.sound.play(-1)
    
  • edited 3:24PM

    Ok, that's a weird error indeed. As a first step, I would see if you still get this error with the most recent version of OpenSesame. Right now you're using 0.26, which is relatively ancient (almost two years old):

    I think there's a good chance that updating will resolve the issue, even though, to be honest, I have no clue what causes it. If an update doesn't resolve things, we'll take it from there.

    Cheers!

    There's much bigger issues in the world, I know. But I first have to take care of the world I know.
    cogsci.nl/smathot

  • edited 3:24PM

    As a potential temporary workaround: could you check if the 'psycho' back-end provides the same error?

  • edited December 3

    Hi,

    I am having the same error with the latest version of OpenSesame. I am able to run the experiment full screen using expyriment and psychopy backend but not the legacy backend.

    Here is my experiment https://drive.google.com/file/d/1aTYxVVqzueYsp-ih2bEcFO9VHK9LfWxH/view?usp=sharing

    Thanks!
    Han

Sign In or Register to comment.