Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

[solved] Running OpenSesame on XP

edited March 2013 in OpenSesame

I've been running OpenSesame on Windows 7 for a few weeks without any issues so far, and I believe I've used it in Vista as well. However, this afternoon I've had issues opening OpenSesame while on XP computers. I've tried it on two computers - on one first downloading the windows version and then attempting the portable version, and on another with just the portable version, and both give the same error. The same portable version worked fine on a Windows 7 computer, however. I've tried uninstalling/reinstalling and restarting the computers but still get the same error.

The download lists XP/Vista/7, and screenshots show 0.24 running in XP, does the current version still run in XP? Assuming that it does, any suggestions on getting it to work?

This is the error I receive:
C:\Program Files\OpenSesame\opensesame.exe
This application has failed to start because teh application configuration is incorrect. Reinstalling the application may fix this problem.

The computer is running Windows XP Professional with Service Pack 3. I believe it is a 32-bit version of Windows, if this is relevant.

Thanks in advance to anyone that can help.


  • edited 5:29PM

    Hi Jacob,

    OpenSesame is tested primarily on Windows XP and Ubuntu Linux systems. So yes, it should certainly work.

    The error that you report is quite puzzling. It appears that it's not really a crash of OpenSesame per se, but that for some reason it fails to start altogether. Do you see an opensesame.exe.log file with an error message in the OpenSesame folder? If so, could you please post it?

    Are there some peculiarities of the system that you're aware of? Security settings, strange characters in path-names, software that might conflict?


  • edited 5:29PM

    Hi Sebastian,

    Thank you for the quick response and I apologize for the slight delay in my reply.

    You are correct that it doesn't seem to open at all. I do not see any sort of log file in the folder. What would the file be named?

    The computers in question are computers in the labs at Florida State University. There are not any strange characters in the path names. I also can not think of any software that might conflict. However, it is possible that there are some sort of security settings set by our IT guys. I will look into this tomorrow.

    Today I attempted running it on a handful of other computers running XP in the department. It worked on 2 of them but I got the same error above on 5 of them. I am trying to find any differences between the ones that it is working on and the ones that it isn't working on, but have yet to find any. The computer model apparently is not the issue, so it seems it is something software based. It is not the version of XP either (XP 2002 Professional Service Pack 3 works on some but not others). Whether it is connected to the internet or not also does not seem to matter.

    It is indeed quite puzzling. I'll talk to the IT people here tomorrow to see if they have any ideas. In the mean time, any other things you can think to look at?

    BTW, I've still been working on a few things from home and on Windows 7 computers here and have had very few problems so far despite me not knowing anything about Python. Thanks for such a great program and responding to all the questions people post so quickly!

  • edited March 2012

    Hi Jacob,

    It's probably useful to know a bit about how OpenSesame works, also potentially for the IT guys. OpenSesame is basically a large script that requires a Python interpreter to run. This is not obvious in the Windows packages, because the script and the interpreter are compiled into a single .exe file. But the idea is still the same.

    If OpenSesame crashes, the interpreter generates an error, which is stored in opensesame.exe.log. This error is generally fairly informative and useful for debugging. But if the Python interpreter itself crashes, you get almost nothing. Just these horrible generic Windows error messages. I suspect that the latter is happening here.

    To be honest, I don't have any idea about what could cause the crash. I suspect that it has nothing to do with any 'configuration', as the error implies, but something with conflicting dlls or the like. What you could do is try a different package that has been created by Edwin, from University Utrecht. He used a different method of packaging the Python interpreter. Perhaps it works on your computers. If not, using his package, you could try running the interpreter (python.exe) by itself to see if it also crashes.

    Keep me posted! I haven't seen this error myself, but a few days back I heard the same thing from someone using OpenSesame for a class. So I'm keen to resolve it.


  • edited 5:29PM

    Hy there,

    i'm using openSesame for my diploma thesis at University of Konstanz, so btw Thanks for developing openSesame, great stuff! :-)
    I am working with openSesame for est 1.5 years running win7 32/64bit on several computers at home, by now never had problems, even on an netbook.
    Currently our department changed computers, so at the office i am using a xp 32bit/dual core system, and now i can't get my experiment running. openSesame stocks after the "subject-number"-dialog. unfortunately i have no idea why. i can run my experiment even in an virtualbox, xp 32bit, but on that real way

    cheers & thanx,

  • edited 5:29PM

    Hi Bjorn,

    That's really weird. Could you describe a bit more specifically what happens? Does the program crash completely (i.e. the window vanishes), or do you get some kind of error message in the debug window or the opensesame.exe.log file? Does it happen with all back-ends and all experiments?

    Btw, good to hear that you've been using OpenSesame for so long already! You've been there pretty much from the start then.


  • edited 5:29PM

    Hi Sebastiaan,

    thx for your reply!

    I can only use the legacy backend, since i'm using an modified version of the mediaplayer plugin to present short videos.

    What happened is:

    • i clicked run to start the experiment (fullscreen / window doesn't matter),
    • then type in an subject number,
    • click ok,
    • the subject number dialog closes
      and ... nothing happens. ?

    Nothing seems to be logged about that error, except for some Unicode/Decode exceptions, but i can't track if that is associated. I guess

    Meanwhile i have found a solution. I am partly using long pathnames and many subfolders, XP doesn't seem to cope with that in the end. I have renamed and shortened my folder structure, e.g. without spaces, changed german umlaut marks like 'ö' to 'oe', now it works fine.
    btw, i am using the portable version in an dropbox account, so i am the most flexible, since i use several computers. win7 doesn't care about the pathnames or special characters like 'ö'.


  • edited 5:29PM

    Hi Bjorn,

    Ah right, I see. There is a bug in 0.25 were special characters in filenames cause trouble (Issue 74). It should be resolved in 0.26. If you decide to check out the 0.26 pre-release, please let me know if this issue has indeed been fully resolved.


  • edited 5:29PM

    Hi Sebastiaan,

    thx a lot!

    I will love to test the new release after I will have finished my current experiment ;-)

    Any idea why 0.25 is producing this bug in XP, but not in Win 7 ?

    Cheers, Bjorn

  • edited 5:29PM
    Any idea why 0.25 is producing this bug in XP, but not in Win 7 ?

    It undoubtedly has something to do with the character set that is used, but beyond that I don't know. Special characters in filenames are notoriously tricky, and require all kinds of operating system specific hacks. Good to hear that it works on Win 7 though.

  • edited 5:29PM

    Hi there,

    I just wanted to reply to the very first post from Jacob. Last week I had the same problem on a windows XP PC in our lab. The PC was not connected to the internet and kept giving me the same error message

    "C:\Program Files\OpenSesame\opensesame.exe This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem."

    After connecting the PC to internet and updating XP and the .net framework, OpenSesame worked as expected.


  • edited 5:29PM

    Hi Michel,

    Thanks for your info. This "configuration error" is something that users occasionally report (just yesterday, for example), and I don't have a clue what causes it, beside the obvious statement that there must be some incompatibility somewhere.

    So it's good to know that updating windows and the .NET framework solved it, at least in your case!


  • edited October 2012

    Just last week, I have encountered this problem too. The problem lies with PyGame. On some systems, a different setup is used (where or how: I haven't the foggiest, but I'm guessing MichelQ has found a promising direction). If you run from source: install PyGame on the PC where you want to install OpenSesame. Then it should work.

    If you work with the portable version: install Python 2.6 and Pygame on the PC of your choice, then go to the site-packages folder of Python Portable included with OpenSesame Portable (opensesameportable-0.26-4-win32\PortablePython_1.1_py2.6.1\App\Lib\site-packages), delete the pygame folder and the file 'pygame-1.9.1-py2.6.egg-info' (and all the other pygame .egg-files). Then go to the site packages folder of the installed version of Python 2.6. Copy the pygame folder and the file 'pygame-1.9.1-py2.6.egg-info' and place these in the site packages folder of OpenSesame Portable (again, see here: (opensesameportable-0.26-4-win32\PortablePython_1.1_py2.6.1\App\Lib\site-packages)).

    I can imagine that for the standalone version, the solution is more difficult, since the version of PyGame that comes with it isn't easily adaptable.

  • edited November 2012


    just wanted to add that today I had the same error on another xp PC. This time I only downloaded and updated the .net framework (On the other case I also updated windows to the latest service pack etc) which removed the error.

    So this makes 2 cases on different PC's where updating the .net framework removed the error.

    edit: Keep in mind that for xp and older pc's you probably need the older version of .net framework (3.5) instead of the latest (4.5).


Sign In or Register to comment.