Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

OpenSesame soundrecorder plugins v0.15 with OS 3.1.9


I need to record sound in an OS script.
I tried to install OpenSesame soundrecorder plugins v0.15 and it does not seem to work (unless I missed something). Is it normal ?



  • Sorry but finally the plugin seems to work.
    It's just that I unzipped the main folder in opensesame_plugins and I needed to unzip the two small folders instead. (sound_start_recording and sound_stop_recording).


  • Finally I tried the plugin in OpenSesame 3.1.9 and OpenSesame 2.9.7 and it does not seem to work.

    I have the following error message:
    File "C:\Program Files (x86)\OpenSesame297\plugins\sound_start_recording\", line 37, in
    ImportError: No module named acodec

    From that point I tried to install pymedia but I did not succeed. It does not want to install on new python 2.7 version. (it says that Python 2.7 is required while it is already installed on my PC)
    Would someone have an idea, please ?

  • Hi Boris,

    As far as I know, the plugin is a little buggy with the newer Opensesame versions ( With the older versions it should work though.
    The error message suggest that you need yo install Pymedia somehow. Did you follow these instructions? In any case, if you need help, we need more information. General Python questions (like how to install Pymedia), can also be directed to stackoverflow. There you get answered potentially quicker (if they're not already there).


  • Hi Eduard,

    Thanks. After being unsuceesful in installing pymedia, I tried again to use soundrecorder with OS 2.9.4 and now it works.


  • Hi there,
    I am also having some trouble with installing the plug-in. I tried using the pip command in the debug window and I have tried manually moving the files across to the opensesame/share directory. I get the following error:

    pip.main(['install', u'C:\\Users\\localadmin\\OpenSesame\\opensesame_soundrecorder_plugins\\sound_start_recording\\']) Invalid requirement: 'C:\Users\localadmin\OpenSesame\opensesame_soundrecorder_plugins\sound_start_recording\' It looks like a path. Does it exist ? You are using pip version 8.1.2, however version 9.0.1 is available. You should consider upgrading via the 'python -m pip install --upgrade pip' command.

    Any help would be great!

Sign In or Register to comment.