Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

crash opensesame

Hello everyone,
I was using opensesame2.9 and it worked quite well (but so slow). I installed the latest version yesterday and have made all the changes so my script could run. I only use the GUI to make the script and i'm not good enough yet to write something clean so I'm convinced that there is room for a lot of improvement.
My problem is that opensesame crashed during a test experiment. I use the xperiment backend as I'm using the parallel port trigger plugins. I was in fullscreen.
My study is running now in windowed mode to see if this could help. I will then try with the psycho backend if it still crash.
Thanks for your advice,

Here is the debug report:
Unexpected error

item-stack: experiment[run].loop21_od1[run].trialpart21[prepare].images_stim[prepare]
exception type: IndexError
exception message: tuple index out of range
time: Wed Jun 20 15:58:14 2018

File "C:\Program Files (x86)\OpenSesame\lib\site-packages\libqtopensesame\misc\", line 154, in run
File "C:\Program Files (x86)\OpenSesame\lib\site-packages\libopensesame\", line 449, in run
File "C:\Program Files (x86)\OpenSesame\lib\site-packages\libopensesame\", line 103, in execute
File "C:\Program Files (x86)\OpenSesame\lib\site-packages\libopensesame\", line 122, in run
File "C:\Program Files (x86)\OpenSesame\lib\site-packages\libopensesame\", line 51, in run
File "C:\Program Files (x86)\OpenSesame\lib\site-packages\libopensesame\", line 122, in run
File "C:\Program Files (x86)\OpenSesame\lib\site-packages\libopensesame\", line 341, in run
File "C:\Program Files (x86)\OpenSesame\lib\site-packages\libopensesame\", line 102, in execute
File "C:\Program Files (x86)\OpenSesame\lib\site-packages\libopensesame\", line 142, in prepare
File "C:\Program Files (x86)\OpenSesame\lib\site-packages\libopensesame\", line 124, in prepare
File "C:\Program Files (x86)\OpenSesame\lib\site-packages\libopensesame\", line 142, in prepare
File "C:\Program Files (x86)\OpenSesame\lib\site-packages\libopensesame\", line 146, in prepare
temp_name, element.element_name
File "C:\Program Files (x86)\OpenSesame\lib\site-packages\openexp_canvas\", line 349, in exit
File "C:\Program Files (x86)\OpenSesame\lib\site-packages\openexp_canvas\", line 770, in prepare
File "C:\Program Files (x86)\OpenSesame\lib\site-packages\openexp_canvas_image\", line 33, in prepare
File "C:\Program Files (x86)\OpenSesame\lib\site-packages\psychopy\visual\", line 97, in init
self.setImage(image, log=False)
File "C:\Program Files (x86)\OpenSesame\lib\site-packages\psychopy\visual\", line 289, in setImage
setAttribute(self, 'image', value, log)
File "C:\Program Files (x86)\OpenSesame\lib\site-packages\psychopy\tools\", line 137, in setAttribute
setattr(self, attrib, value)
File "C:\Program Files (x86)\OpenSesame\lib\site-packages\psychopy\tools\", line 27, in set
newValue = self.func(obj, value)
File "C:\Program Files (x86)\OpenSesame\lib\site-packages\psychopy\visual\", line 276, in image
File "C:\Program Files (x86)\OpenSesame\lib\site-packages\psychopy\visual\", line 969, in _createTexture
data.shape[1], data.shape[0], 0,
IndexError: tuple index out of range


  • So, I was running with psycho in fact. I tried with windowed mode and it crashed saying python has crashed.
    I tried with expyriment and it seems to work, even in full screen. It's slower to lauch though. And very strange: I use tightVNC to look at the screen of the study when running. If I use expyriment I can't see the succession of screen. Only the first one...
    It should work for now but this is very strange


  • Hello everyone,
    Nobody has got advice to give me ?
    Expyriment is acting weird. The succession of my stimulus dies along the the end of the study nothing hapened in the good way. So it is not a solution for me anymore.
    I will try with Legacy today or go back to opensesame2.9 so I can run my study next week.
    Have you ever heard of problem like that on windows7 ?

  • Hi Johan,

    Can you upload your experiment together with a description of what it is that you want it to do? Then, I'll have a look on whether I can see what the problem is. And once your at it, can you also post the version of your libraries, in particular psychopy and expyriment ( You can get it from Tools-->System information)?


    Thanked by 1Johan_P
  • Hi Eduard,
    The script works enough with Legacy backend...
    I join the files you asked.
    My script runs a study with 2 blocks of 4 parts. Each part is exactly the same except for the order of the stimulus S2 and the code of the trigger.

    This is a go/no go task
    In each part I asked for an ISI with a non variable duration. I have a cross on screen with this duration. then I have a sound S1, a fixed time fixation cross and then a colored dot red or green on the screen.
    According to the color, the participant push a buton or not.

    Do you need more info?


  • Does the error occur right in the beginning of the script, or only a certain times in the experiment? I'll have a look during the weekend.

  • With psycho backend, it is totally unpredictable. it just crash sometimes
    With Expryriment, it is never the same part which is badly timed. It seems to happened more toward the end of the script so I would look for a memory problem.
    With legacy it seems to work ok...

    thank you,

  • Hi Johan,

    I'm sorry, but I can't open your experiment because of the parallel port init item. If you could remove it and upload it again, I could give it another try. Once at it, it'd be helpful if you could simplify the experiment as much as possible while still preserving the error. Although, there is a fair chance that the problem only arises because of the complexity and/or the parallel port part. At least the error that you posted above suggests that something broke that is not supposed to break and that the problem is not just a simple coding error, or something like that.

    With legacy it seems to work ok...

    Would that be an option for you? Using legacy ?

    Other than that, there is not much I can do, I'm afraid. Sorry.


  • Hi Eduard,
    The error is never timed and labelled in a same way so I don't want to reduce the script. If I remove the parralel port , you will be able to run but it will not be the same study.
    I will work this week with legacy backend even if the timing are not so precise (says opensesame help page). Then I will do testing with the script if I have the time.
    Thanks for you help.

Sign In or Register to comment.