Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

Binomial test fail - beginner's question

edited October 2018 in JASP & BayesFactor

In JASP my data has two columns 'id' and 'gender' which has a list of items 'male' or 'female'
I select Binomial Test, drag gender into the right-hand box and get the error message:

! Error in if(any(df[[name]]) == '.')) next:
missing value where TRUE/FALSE needed

What have I done wrong? Thanks for any help.


  • Can you send the JASP file, perhaps only with the gender column?

  • edited October 2018

    Thanks for your reply - file enclosed. The same error occurs even with just one column.

  • I am not sure what goes wrong...
    I have tried this with and the latest, and it works like a charm, for both the Bayesian as well as the classical analysis.

    Thanked by 1normanp
  • I'm using - it was the only version I could find that was 32bit for Ubuntu 16.04 Xenial.
    Maybe it's a bug?
    I'd love to use v0.9.x but see no way of doing so. Maybe I can compile from source??
    Thanks again

  • edited October 2018

    Mind you I'd be surprised if this most basic feature was broken!! By the way the Bayesian version works OK.

  • I'll attend some other team members to this post

    Thanked by 1normanp
  • Hi normanp,

    Could you please try our flatpak build?

    Let me know how that works out for you.


    Thanked by 1normanp
  • OK - will do. Should I remove first?

  • I don't think that that's necessary, though, I do think that that's good practice in general.

    Thanked by 1normanp
  • edited October 2018

    flatpack installs OK, but it cannot install jasp:

    flatpak install
    The application org.jasp.JASP depends on runtimes from:
    Configure this as new remote 'flathub' [y/n]: y
    error: No such ref 'app/org.jasp.JASP/i386/master' in remote org.jasp.JASP-origin

    I assume the 'flatub' bit was ok because when I repeat the command:
    flatpak install
    error: No such ref 'app/org.jasp.JASP/i386/master' in remote org.jasp.JASP-origin

  • Hi normanp,

    It seems that you're running an 32bits version. We don't have a flatpak version for that. Instead, could you build JASP from source? The instructions are given here


  • edited October 2018

    Maybe there's no 32bit version?
    (by the way I did restart after flatpack install & use sudo with the above command)

  • Looking at
    jasp is not there at all - no wonder it couldn't install!

  • There's no 32bits version of our flatpak build at the moment.

  • Sorry - got out of step with your comments.
    That build guide specifies Ubuntu 17+, so I assume it won't work. I really can't face compiling from source with possible dependency problems.

    All this just to get the simplest beginner's text book example working in
    I really cannot believe that this was not noticed in that version!

  • I'll see if we can get a 32bits flatpak version. I'll ask my wizard to free up some time.

    Thanked by 1normanp
  • That would be great! After all Ubu 16.04 LTS is supported til 2021

    By the way when started from the command line jasp produces quite a series of error messages. It then appears to run fine for example doing Bayesian Binomial etc etc (in fact everything I have tried, but not standard Binomial) - enclosed.

  • By messing about I think I have it working (Ubuntu 16.04 32bit, v

    Open any file (eg a csv, one column headed gender, with a list of either male or female)
    Before doing anything else, click on the header of the column to open the Value-Label box.
    Change the label of the FIRST item listed to a number (anything eg 0, 1, -5, 2.4, 999)
    Now run the Binomial Test - it now seems OK
    Alright - in the results table the numeric label is used in the Level column - rather unfriendly.

    I suppose this must be a bug?

Sign In or Register to comment.