Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

OpenSesame 0.27.1 'Frisky Freud' available

edited February 2013 in OpenSesame

OpenSesame 0.27.1 is the first maintenance release in the 0.27 'Frisky Freud' series. This release doesn't introduce any new functionality, but addresses bugs that were introduced (or not fixed) in 0.27.

As always, you can download OpenSesame from http://osdoc.cogsci.nl/

If you are upgrading from 0.26, please read the 0.27 release notes.

Bugs fixed:

  • Fix numeric values in form checkboxes
  • Do not show start-up tab when opening a file directly
  • Catch errors due to missing closing quotations when editing a sketchpad element
  • Fix super() error in form plug-ins
  • Fix variable background color in sketchpad item
  • Catch recursion errors in general script
  • More comprehensive HTML and font implementation in psycho and legacy back-ends
  • Do not interpret special character sequences in script
  • Fix joystick plug-in
  • Fix exp.get_file() in opensesamerun
  • Fix option splitting by return in form_multiple_choice plug-in
  • Fix a bug where timeouts were always counted as incorrect

Windows packaging:

  • Include joystick plug-in

Ubuntu/ Debian packaging:

  • Include joystick plug-in
  • Include repeat_cycle plug-in

There's much bigger issues in the world, I know. But I first have to take care of the world I know.
cogsci.nl/smathot

Comments

  • edited 4:32PM

    It has come to my attention that on some Windows systems the update checker causes a "hard" crash. The symptoms are: OpenSesame will inform you that a newer version is available. When you close the update notification, the program will crash.

    There are two ways to resolve this issue:

    Upgrade

    Download and install OpenSesame 0.27.1.

    Disable the automatic update checking

    You can disable the automatic update checking in the OpenSesame preferences. However, if you cannot start the program, you cannot modify the preferences. Fortunately, you can do this from the command line as well.

    In the OpenSesame folder (that contains opensesame.exe), create a batch file called opensesame_no_updates.bat. Open this batch file (for example in notepad) and enter the following line:

    opensesame.exe -c auto_update_check=False

    Next, close the batch file and double-click on it to start OpenSesame without checking for updates. The next time you can start OpenSesame normally, because your preferences will be remembered.

    There's much bigger issues in the world, I know. But I first have to take care of the world I know.
    cogsci.nl/smathot

  • edited March 2013

    I'm terribly late with this, but there seem to be no new deb packages for .27 in http://files.cogsci.nl/software/opensesame/

    Upgrading from a deb was hilariously simple last time; did you drop those?

  • edited 4:32PM

    Hi Wouter,

    I don't upload the deb files separately anymore, because OpenSesame is available through a number of repositories:

    Cheers!

    Sebastiaan

    There's much bigger issues in the world, I know. But I first have to take care of the world I know.
    cogsci.nl/smathot

Sign In or Register to comment.