Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

Error with Pyhton encoding the user path with accent ?

Hello everyone,

I would like to share my recent experience:

  • I run an experiment on last friday: no problem.
  • I run it yesterday (on monday) : an error appeared right after I choose the file or saving the name of the opensesame .csv file. I couldn't even run my task.
 'ascii' codec can't encode character u'\xe9' in position 37: ordinal not in range(128)
  • After trying with severals tasks, the same error message keeps appearing all over again with all my tasks. The exact same error message.
  • I created another User session on my laptop running with windows 10 as my current user session is written with an accent, I've created the new one with no accen, just .. you know to see ...
  • Well, no error anymore. BUT WHY ? and HOW did this happen in just a couple of days without changing anything to my laptop ? It means I have to use my other session to run all my experiments now. This is quite confusing ...

FIY: Using windows 10, even if you change the user name directly in the settings options or on your microsoft account, it does not change it into the USER PATH. One provided solution by W10 helpers forum, is to modify it directly into you hardrive user file by creating another adminstrator session 'but it can crash'. Well, yes, I've just tried with a random new session and it's literraly erasing all files by creating an alternative temporary session ...

I am wondering why .. suddently ... ?

Have a good day,


  • Hi Coline,

    In the debug window, you should find a more elaborate error message (traceback) that might helps us to pinpoint where this error comes from. Could you post the traceback here?



  • Hello, here is the infirmation I got, that's all

    Thanks Coline

  • Hi Coline,

    If you press Ctrl+D, you will show the debug window. Could you post everything that's shown in there from the moment that the experiment starts until the moment that you see this crash?



  • Hei again,

    Here is what I got:

    Python 2.7.13
    * Type "help()", "copyright()", "credits()" or "license()" for more information.
    * Use the "print([msg])" function in inline_script items to print to this debug window.
    * Inspect inline_script variables when an experiment is finished.
    'ascii' codec can't encode character u'\xe9' in position 37: ordinal not in range(128)
    time: Mon Apr 15 13:58:07 2019

  • Hmmm, that's not very informative. If you look under Menu → Tools → Preferences, which runner is selected?

  • Hello.

    I guess it is the external runner:

  • edited April 2019

    Hi Coline,

    Ok, that clarifies things a bit. It's seems to be a bug, but probably specific to the external runner, which is rarely used. So we'll fix that. And for now you can workaround the issue by selecting the multiprocess runner.



  • Indeed, it is working well now. Thanks a lot for your help.

    Still, I am curious... do you have any idea on how did the bug appear ?

  • Good! And no, for now I don't know what caused the bug. But it's on the to-do list for the next maintenance release (3.2.8)!

Sign In or Register to comment.