Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

[solved] v 0.27 experiment won't open (says variable not set in an item)

edited March 2013 in OpenSesame

I just upgraded to 0.27, and now my experiment won't open... pretty sure it's a new thing, though I haven't run this experiment in a couple of months. I don't think I changed anything since the last time it was working on 0.26.

Here's the error text:

Error: Failed to open 'C:/ [bunch of folders] /essa1.opensesame.tar.gz'
Description: Error: Runtime error
Description: Variable 'task_decis_fg' is not set in item 'decis_n_task'.
You are trying to use a variable that does not exist. Make sure that you have spelled and capitalized the variable

name correctly. You may wish to use the variable inspector (Control + I) to find the intended variable.

The variable is a hex color code to set foreground colors in various sketchpad items, and I think the item is a sketchpad item. So I think it's telling me that, since a variable in a sketchpad item doesn't have a value set, I can't open my experiment. Obviously, I would like to open the experiment to see how to get that variable value set, if that's the problem.

Any ideas or guidance would be greatly appreciated.


  • edited 8:19AM

    Indeed, OpenSesame tries to evaluate the foreground color, and fails to do so when the foreground is specified via a variable that is only available at runtime (issue). I'll fix this for the next bug-fix release, but for now you can use the following work-around:

    Using a text editor

    Open the script in any text editor and type the following line at the top of the file:

    set task_decis_fg dummy

    This will make sure that the variable is set, even when the experiment is not running. If your experiment is in opensesame.tar.gz format, you can extract the script with a tool like 7-zip.

    Using OpenSesame 0.26

    Open the experiment in OpenSesame 0.26, click on 'Show script editor' and add the above line to the top of script. After applying the changes and saving the experiment, you should be able to continue working in 0.27.

    Thanks for bringing this to my attention!

  • edited 8:19AM

    Awesome. As always, thanks a ton.

  • edited 8:19AM

    Thanks, Sebastiaan. This seems to have worked just fine. If I can figure out how to mark this "resolved," I will.

Sign In or Register to comment.