Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

[open] OpenSesame_pre-8: sketchpad in psychopy

edited September 2012 in OpenSesame

Hi Sebastian.

Here I reported a problem of OpenSesame 0.26 with the text display item in Psycho backend (0.26 had problems also with the sketchpad inside Psycho). With the pre-releases, it seems solved, indeed the text now appears as it has it should. However, there remains a problem when I use the sketchpad. In my 1366x768 monitor, the sketchpad text and image are moved toward the right of the screen. Moreover, the sentences go to a new line too early, as if OpenSesame doesn't recognize the screen size. If I set the screen size to 1024x768, the sketchpad appears to the center, although it go to a new line too early. Are these problems known? Do you think they can be solved in future?

Cheers,

Andrea

Comments

  • edited 4:16PM

    Hi Andrea,

    Thanks again for your feedback. I wasn't aware of those issues, but they should be fixed now, both on GitHub and in the latest pre-release package.

    Please let me know if the issues are still there, or if you encounter new bugs!

    Cheers,
    Sebastiaan

  • edited 4:16PM

    Hi Sebastian.

    The sketchpad seems to work perfectly now. Thanks!

    I note another problem about text display in Psycho. There appear a number of little orizontal dashes above the text lines. I don't remember this happening with the other pre-releases (but I may be wrong). Of course this doesn't happen with 0.26.

  • edited 4:16PM

    Ok, that's odd. I don't see this myself, but it sounds like something that could depend on your operating system, the font, and the version of PsychoPy (difficult to pinpoint, in other words). If you run the following inline_script ...

    from psychopy.visual import TextStim
    stim = TextStim(win, text='Do I show dashed lines?')
    stim.draw()
    win.flip()
    self.sleep(1000)

    ... does the same thing happen?

  • edited September 2012

    No, the script doesn't show the dashed lines. I too had imagined that it was a complex problem. Of course, it depends on my particular experiment structure. I tried the same experiment both with OS pre-8 ran from source and standalone version, and the problem remains the same.

    Update:

    Anyway, I discovered that the dashed lines problem occurs mainly when the font size of the text display is set to 18 and the font family is 'mono'.

Sign In or Register to comment.