Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

[solved] Opensesame 0.27pre1 error: "No module named PIL"

edited July 2012 in OpenSesame

I tried running the latest Opensesame snapshot from github and it starts up fine. If I drag one of the new form items into the experiment tree however, I get the error message

"No module named PIL"

I guess Opensesame tries to import the Python Image Library, but isn't this imported with "Image"?
Entering

"import Image"

into my Python interpreter gives no problems, so the Python Image Library is correctly installed

Comments

  • edited 1:45PM

    I suspect this has to do with the version of PIL that is installed. There's some ambiguity about the proper way to import PIL. Whether it is

    from PIL import Image

    or

    import Image

    If you try the first import statement in a Python console, do you also get an error? In that case, I'll probably add a 'try... except' statement to fall back to the second import statement if the first fails.

    Thanks!

    There's much bigger issues in the world, I know. But I first have to take care of the world I know.
    cogsci.nl/smathot

  • edited July 2012

    from PIL import Image
    Gives me the same error: No module named PIL.
    I think catching this with a try/except is a good idea

  • edited 1:45PM

    Fixed. I also uploaded a pre-release package that may be useful for testing: http://files.cogsci.nl/software/opensesame/pre-releases/

    Very early days though, so expect bugs!

    There's much bigger issues in the world, I know. But I first have to take care of the world I know.
    cogsci.nl/smathot

Sign In or Register to comment.