Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

Bug report OS 0.27~pre16

edited October 2012 in OpenSesame

All platforms:

Bug: When using the "/" key in the allowed keys of a keyboard_response item, you get the following error message:

Error: OpenExp error
Description: The key '/' is not recognized by the psycho keyboard backend. Please refer to http://pyglet.org/doc/api/pyglet.window.key-module.html for a list of valid keys.

I haven't tested if this occurs for other special keys (other than alphanumerical) as well, but maybe the mapping of the keys that can be entered in 'allowed responses' to the psychopy key has some discrepancies.


Platform: Win7

Bug: The synth_item does not generate a sound when using the expyriment back-end. It works fine with the legacy backend. Settings in synth item are: 100 Hz with a length of 250ms and a duration of 0 ms.

Comments

  • edited 11:41PM

    Just to line all the bugs up that you reported here and in previous posts (thanks!), and see how far along we are with 0.26~pre17 (uploading as I write this):

    Bug:

    When using the "/" key in the allowed keys of a keyboard_response item, you get the following error message:

    Status solved: This should be resolved. It was a result from the fact that PyGame and PsychoPy use different conventions for key names. But I added a(n imperfect) translation mechanism.

    Bug:

    Regarding the sound not working on the Psycho and Xpyriment backends:

    Status solved: This should be solved. It was a result of the order in which the display and the sound was initialized.

    Bug:

    Sometimes when an experiment is started in windowed mode and you switch to another window (outside OS) after which you switch back to the experiment window again, it does not register any key presses anymore (including ESC). You have to force quit OpenSesame or kill the experiment window with xkill

    Status unconfirmed: I still haven't encountered this problem, so it's probably still in there. I'm not sure why you get this issue (on both Windows and Ubuntu, right?) and I don't... Very annoying, but I'll keep testing.

    Bug:

    Additionally, when you run the experiment in full screen, you don't get to see the consent form at all; you only get a black screen with a mouse cursor. Once you click anywhere in that black screen with your mouse, you get to see the consent form for a couple of frames, after which the screen goes black again.

    Status unresolved: This issue probably has to do with the custom mouse cursor in the legacy back-end. So I know where to look, but I haven't gotten around to fixing it.

    Bug:

    Regarding the bug with copy() function in the Expyriment back-end.

    Status unresolved: I reported that here, so we'll just wait until Florian (hopefully) fixes it.

    The rest of the issues that you posted were are specific to the packages in your Python configuration, right? Or did I forget to include something?

    Cheers,
    Sebastiaan

    Buy Me A Coffee

  • edited 11:41PM

    The rest is indeed resolved, or is specific to my own python environment. Thanks!

Sign In or Register to comment.

agen judi bola , sportbook, casino, togel, number game, singapore, tangkas, basket, slot, poker, dominoqq, agen bola. Semua permainan bisa dimainkan hanya dengan 1 ID. minimal deposit 50.000 ,- bonus cashback hingga 10% , diskon togel hingga 66% bisa bermain di android dan IOS kapanpun dan dimana pun. poker , bandarq , aduq, domino qq , dominobet. Semua permainan bisa dimainkan hanya dengan 1 ID. minimal deposit 10.000 ,- bonus turnover 0.5% dan bonus referral 20%. Bonus - bonus yang dihadirkan bisa terbilang cukup tinggi dan memuaskan, anda hanya perlu memasang pada situs yang memberikan bursa pasaran terbaik yaitu http://45.77.173.118/ Bola168. Situs penyedia segala jenis permainan poker online kini semakin banyak ditemukan di Internet, salah satunya TahunQQ merupakan situs Agen Judi Domino66 Dan BandarQ Terpercaya yang mampu memberikan banyak provit bagi bettornya. Permainan Yang Di Sediakan Dewi365 Juga sangat banyak Dan menarik dan Peluang untuk memenangkan Taruhan Judi online ini juga sangat mudah . Mainkan Segera Taruhan Sportbook anda bersama Agen Judi Bola Bersama Dewi365 Kemenangan Anda Berapa pun akan Terbayarkan. Tersedia 9 macam permainan seru yang bisa kamu mainkan hanya di dalam 1 ID saja. Permainan seru yang tersedia seperti Poker, Domino QQ Dan juga BandarQ Online. Semuanya tersedia lengkap hanya di ABGQQ. Situs ABGQQ sangat mudah dimenangkan, kamu juga akan mendapatkan mega bonus dan setiap pemain berhak mendapatkan cashback mingguan. ABGQQ juga telah diakui sebagai Bandar Domino Online yang menjamin sistem FAIR PLAY disetiap permainan yang bisa dimainkan dengan deposit minimal hanya Rp.25.000. DEWI365 adalah Bandar Judi Bola Terpercaya & resmi dan terpercaya di indonesia. Situs judi bola ini menyediakan fasilitas bagi anda untuk dapat bermain memainkan permainan judi bola. Didalam situs ini memiliki berbagai permainan taruhan bola terlengkap seperti Sbobet, yang membuat DEWI365 menjadi situs judi bola terbaik dan terpercaya di Indonesia. Tentunya sebagai situs yang bertugas sebagai Bandar Poker Online pastinya akan berusaha untuk menjaga semua informasi dan keamanan yang terdapat di POKERQQ13. Kotakqq adalah situs Judi Poker Online Terpercayayang menyediakan 9 jenis permainan sakong online, dominoqq, domino99, bandarq, bandar ceme, aduq, poker online, bandar poker, balak66, perang baccarat, dan capsa susun. Dengan minimal deposit withdraw 15.000 Anda sudah bisa memainkan semua permaina pkv games di situs kami. Jackpot besar,Win rate tinggi, Fair play, PKV Games