Welcome!

Sign in with your CogSci, Facebook, Google, or Twitter account.

Or register to create a new account.

We'll use your information only for signing in to this forum.

Supported by

Problems with displaying Arabic letters in OS

Hi everyone,

I need to do a linguistics experiment in Arabic using OS.
I really tried hard to figure out the Arabic font issue as I write the sentences in Arabic (connected letters, as shown in OS1.jpg), but the OS displays them as disconnected letters (as in OS2.JPG) (please see attached photos!). I also attached the OS file itself.

I came across this discussion link (please see here: http://forum.cogsci.nl/index.php?p=/discussion/2243/arabic-script-in-opensesame), but the problem seems unresolved yet.

Have you known a solution or someone from the forum who knows the solution?

I also put an Arabic font in the file pool but in vain; the Arabic letters are still disconnected.

I really hope you can solve the issue for me, you legends

Look forward to your reply

Best
SAM

os2.JPG 77.3K
os1.JPG 180.7K

Comments

  • sebastiaansebastiaan Posts: 2,667

    Hi Sam,

    I'm afraid that the issue is still the same. This is due to the font-rendering engine used by OpenSesame, which doesn't connect the letters properly; so it's not something that is easily fixed.

    An alternative would be to generate images with text, and present those. Would that work for you?

    Cheers,
    Sebastiaan

    There's much bigger issues in the world, I know. But I first have to take care of the world I know.
    cogsci.nl/smathot

  • samoel99samoel99 Posts: 11

    Thanks a lot Sebastian. I had to do images and it works just fine. I am wondering if I can present the sentence image with multiple options underneath the image, and participants can use mouse to click on the correct option. I tried that but there seems to be sth missing. Do you have any ideas how to do so. I can upload the OS file if you have time to look at it. Much appreciated.
    Sam

  • samoel99samoel99 Posts: 11

    Here's the file. Thanks in advance

Sign In or Register to comment.