Welcome!

Sign in with your CogSci, Facebook, Google, or Twitter account.

Or register to create a new account.

We'll use your information only for signing in to this forum.

Supported by

naming problem

Hi,

I have a problem with my experiment. Some loops/sequences/sketchpads' names start with a number (e.g. 3D_blablabla). On my computer everything is fine, but when I tried it on another computer, every loop/etc. starting with a number is sent to unused items. Then I tried on a few more, and it happens on some devices.

I thought it could be some regional/language settings, but it is not (made it equal on both machines, and still the problem persists).

Do somebody know what the problem could be?

Thanks!
Marija

Comments

  • RoelofRoelof Posts: 85

    The behavior for opensesame 3.1.9 seems to be that any name starting with a number is automatically preceded with an underscore (e.g. '3d' becomes '_3d'), which opensesame version are you using? And on which operating system does the error occur? Is there any consistency in where/when this happens?

  • It happens on Windows, but not on every one (currently it happened on Windows 10). I wouldn't care if OS just renamed it, but it sends them to Unused items, and I have to rename everything and get it back (which is tedious, and also sometimes my changes in the user menus aren't accompanied by changes in the script, and in the end it takes a lot of time to fix all the bugs).

  • RoelofRoelof Posts: 85

    So which version of opensesame are you using?

  • 3.1

  • sebastiaansebastiaan Posts: 2,813

    As Roelof points out, the behavior of 3.1 is to automatically rename items so that they have a name that is also a valid Python symbol: a string of alphanumeric characters and underscores that does not start with a digit.

    It sounds like you created the experiment in an older version that did not enforce this. Is that right? If so, I think the easiest solution would be to open the experiment in the older version of OpenSesame. Change the names so that they , and then re-open the experiment in the latest version. Does that work?

    Thanked by 1pogonophile

    There's much bigger issues in the world, I know. But I first have to take care of the world I know.
    cogsci.nl/smathot

  • Yes, it's fine now - thanks!

Sign In or Register to comment.