Welcome!

Sign in with your CogSci, Facebook, Google, or Twitter account.

Or register to create a new account.

We'll use your information only for signing in to this forum.

Supported by

Repeated-measures ANOVA error with high(ish) number of cells

EdwinEdwin Posts: 655
edited September 2017 in JASP & BayesFactor

Hi all,

JASP is great, thanks for developing it! An issue that has persistent over the past and current versions occurs when the number of cells in a repeated-measures ANOVA is relatively high.

When running a 3x9 rm-ANOVA, I get the following in JASP 0.8.2:

Error message, including stack trace:

This analysis terminated unexpectedly.

Error in complete.cases(x, y): not all arguments have the same length

Stack trace
analysis(dataset = NULL, options = options, perform = perform, callback = the.callback, state = state)

.resultsPostHoc(referenceGrid, options, dataset, fullModel)

t.test(unlist(postHocData[listVarNamesToLevel[[k]]]), unlist(postHocData[listVarNamesToLevel[[i]]]), paired = T, var.equal = F)

t.test.default(unlist(postHocData[listVarNamesToLevel[[k]]]), unlist(postHocData[listVarNamesToLevel[[i]]]), paired = T, var.equal = F)

complete.cases(x, y)

To receive assistance with this problem, please report the message above at: https://jasp-stats.org/bug-reports

The message in 0.7.1.12 used to be Invalid comparison with complex values, and has been reported on GitHub before (raised in September 2015; closed in March 2017 in anticipation of whether it was still a bug in the latest version).

Please note that the issue does not seem to be with the data: Running 2x9 rm-ANOVAs on the same data does work, and I've had the same issue with a completely different dataset. The only common factor seems to be the number of cells.

UPDATE (2017-09-14, 12:34 UTC+0): The same data does work with 2x9 rm-ANOVAs on JASP 0.7.1.12, but not on 0.8.2. On 0.8.2 it does work in a 3x6 design.

Any idea what might be going on?

Cheers,

Edwin

Comments

  • EJEJ Posts: 444

    No idea! Can you attend us to this problem again please (on GitHub)? It would be good to sort this out
    E.J.

  • EdwinEdwin Posts: 655

    Thanks for having a look. I just posted on the linked GitHub Issue, also referencing this Thread.

    Thanked by 2EJ sebastiaan
  • EdwinEdwin Posts: 655

    Solved! After some further digging, we found out that it was in fact the variable naming that caused the error. This should be solved in the next JASP release, and is also avoidable by using non-similar names (specifically: unique two first characters of each variable name).

    Link to GitHub issue where this was solved: https://github.com/jasp-stats/jasp-desktop/issues/2241

    Thanked by 2EJ labovich
Sign In or Register to comment.