Welcome!

Sign in with your CogSci, Facebook, Google, or Twitter account.

Or register to create a new account.

We'll use your information only for signing in to this forum.

Supported by

Cursor on text_input form moving slowly

Hi,

I have a question concerning the cursor speed on the text_input forms.

When participants are typing in the text_input forms the cursor moves very slowly so not all the letters they type are being displayed in the text box. How can I increase the speed of the cursor?

The CogSc Manual Says:

"Forms can be slow, and this is especially noticeable if you are using text input on a slower system. If you find that forms are too slow, you can do a number of things:

Switch to the legacy backend and set Double buffering to 'no' in the backend settings.
Switch to the xpyriment backend and set OpenGL to 'no' in the backend settings. Important: This disables hardware acceleration and decrease the precision of the display-presentation timestamps.
Reduce the number of elements on the form. The speed with which the form is rendered is directly proportional to the total surface of all its elements."

How would I implement this?

Sara

Comments

  • eduardeduard Posts: 1,115

    Hi Sara,

    In the very first item in the overview area on the left (usually it is called "Experiment") you can select the backend from the dropdown menu. There you can choose legacy or expyriment. Actually, you should then also be able to click on the button "back-end settings" to disable openGL, but I think this button doesn't work currently.

    Hope this helps.

    Eduard

  • Thankyou Eduard! This has helped!

Sign In or Register to comment.