Welcome!

Sign in with your CogSci, Facebook, Google, or Twitter account.

Or register to create a new account.

We'll use your information only for signing in to this forum.

Supported by

Has the column order in DataMatrix object changed in semi-recent versions of Opensesame?

neonneon Posts: 64

Hi All,

I've recently run a previous experiment I created in a slightly older version of Opensesame, and it no longer works correctly.
After a bit of poking around, I've noticed that my script to access items in a DataMatrix is returning things in a different order than it used to. Before, it seemed as if it the column structure matched the layout in the Opensesame interface (i.e. the loop item) but now it looks as if it might be alphanumerically sorted by default? Does anyone know if this is the case, because it's well b*ggered up my experiment haha.

Thanks for any advice,

Neon

Comments

  • sebastiaansebastiaan Posts: 2,950

    Hi Neon,

    There was indeed a version (3.1.7) that sorted the columns of the loop table alphabetically. That was a bug due to a change in DataMatrix but was solved as of 3.1.8. So upgrading should solve the issue.

    Cheers!
    Sebastiaan

    There's much bigger issues in the world, I know. But I first have to take care of the world I know.
    cogsci.nl/smathot

  • neonneon Posts: 64

    Thanks @Sebastiaan,

    Unfortunately, things are getting weirder and weirder... I was indeed running 3.1.7 on my office PC, where I experienced the error. I've also noticed it on lab PCs though that are running ver 3.1.5. (I've just double-checked this). I also asked my colleague to check on her office PC (ver 3.1.7) which works fine.

    This seemed to be plausible...But now I've upgraded my office version of Opensesame to 3.1.9 it again it doesn't seem to work?! Do you have any thoughts? Happy to send the code (or outline some code snippets) and explain what's what if you or someone has the time and inclination to have a peek?

    Thanks again for your help as ever,

    Neon

  • sebastiaansebastiaan Posts: 2,950

    Hi Neon,

    Yes, if you have code snippets to illustrate the problem, and a clear description of what exactly happens, then that would be very useful.

    Cheers,
    Sebastiaan

    There's much bigger issues in the world, I know. But I first have to take care of the world I know.
    cogsci.nl/smathot

  • neonneon Posts: 64

    OK - I believe I've gotten to the bottom of it now, having downloaded a couple of versions and diff'ing them:

    So, the original (working) version was done using 3.1.4. All fine.
    When I ran this on my PC using 3.1.7 and re-saved it, it the script alphabetized all of the set-cycle statements (i.e. the loop table items). So, running a version that had been opened / saved in 3.1.7 didn't work on anything any more - which explains why it didn't work in the lab (3.1.5) or later versions (e.g. my recent install of 3.1.9).
    Having pulled down an old version from OSF, this works fine on 3.1.5, 3.1.5 and 3.1.9.
    Suddenly everything is clear. I guess it's good to close this threat if what I am saying is correct?

    Thanks as ever for your help, and I hope you have a fantastic weekend,

    Neale

  • sebastiaansebastiaan Posts: 2,950

    Yes, I suspected as much: Once the experiment has been corrupted, problems will persist in later versions of OpenSesame too.

    Good to hear that it's resolved!

    Thanked by 1neon

    There's much bigger issues in the world, I know. But I first have to take care of the world I know.
    cogsci.nl/smathot

Sign In or Register to comment.