Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

my loop setup is incorrect

I'm having trouble finding information on how to set up loops. I read the documentation but it does not apply to the way my questionnaires. For example, my handedness questionnaire - I input the score if the person selects that value for each question. They can only select one. So B receives a score of 0, L a score of 1, and R a score of 2. When I log the data and read the logger, the output are the values I input as scores for everything. Plus the last value is repeated to the end of the experiment. What am I doing wrong?

HQ_B HQ_L HQ_R HQ_question_text
1 0 2 draw
1 0 2 use a toothbrush
1 0 2 use a bottle opener
1 0 2 throw a ball far away
1 0 2 hammer a nail
1 0 2 hold a tennis racket to hit a ball
1 0 2 to cut through a rope with a knife
1 0 2 to stir with a spoon
1 0 2 to erase something
1 0 2 strike a match
1 0 2 strike a match
1 0 2 strike a match
1 0 2 strike a match
1 0 2 strike a match
1 0 2 strike a match
1 0 2 strike a match
1 0 2 strike a match
1 0 2 strike a match
1 0 2 strike a match
1 0 2 strike a match
1 0 2 strike a match
1 0 2 strike a match
1 0 2 strike a match
1 0 2 strike a match
1 0 2 strike a match
1 0 2 strike a match
1 0 2 strike a match
1 0 2 strike a match
1 0 2 strike a match
1 0 2 strike a match
1 0 2 strike a match
1 0 2 strike a match
1 0 2 strike a match
1 0 2 strike a match
1 0 2 strike a match
1 0 2 strike a match
1 0 2 strike a match
1 0 2 strike a match
1 0 2 strike a match
1 0 2 strike a match
1 0 2 strike a match
1 0 2 strike a match
1 0 2 strike a match
1 0 2 strike a match
1 0 2 strike a match
1 0 2 strike a match

Comments

  • I've linked my loggers but now the program doesn't run at all. I get a black screen and I have to use task manager to get out of it.
    Also, is there a way to remove variables I don't use (e.g. correct response). Most of my questionnaires are multiple choice so there is no 'correct' response.

  • I copied the debug window to see what was happening and the program seems to stall at the beginning. It loads the logo but then stops and I can only see a black screen.
    Hope this information helps solve this problem.

    Python 2.7.13

    • Type "help()", "copyright()", "credits()" or "license()" for more information.
    • Use the "print([msg])" function in inline_script items to print to this debug window.
    • Inspect inline_script variables when an experiment is finished.

    Starting experiment as ExperimentProcess-1
    openexp._canvas.legacy.init_display(): enabling hardware surface
    openexp._canvas.legacy.init_display(): enabling double buffering
    openexp._canvas.legacy.init_display(): video mode ok
    openexp.sampler._legacy.init_sound(): sampling freq = 48000, buffer size = 1024
    openexp.sampler._legacy.init_sound(): mixer already initialized, closing
    experiment.run(): experiment started at Thu Jan 18 13:38:53 2018
    experiment.run(): disabling garbage collection
    7E2DB41990AE4D4F
    c:\users\patric~1\appdata\local\temp\tmpjxyvlx.opensesame_pool\logo_large.png
    c:\users\patric~1\appdata\local\temp\tmpjxyvlx.opensesame_pool\logo_large.png
    c:\users\patric~1\appdata\local\temp\tmpjxyvlx.opensesame_pool\logo_large.png
    c:\users\patric~1\appdata\local\temp\tmpjxyvlx.opensesame_pool\logo_large.png
    c:\users\patric~1\appdata\local\temp\tmpjxyvlx.opensesame_pool\logo_large.png

  • Hi,

    The debug output doesn't show any problems, as far as I can tell. You are using, Opensesame 3.2, right?
    Could you upload your experiment? I'll have a look.

    You can also try to fix it yourself, but removing (or replacing) stepwise items from the experiment, and see when it starts to work again. Maybe you can isolate the problem at hand, like that.

    Eduard

  • Hey Eduard, I am using Opensesame 3.2 but there are some problems with the logger posting to the excel sheet. I have attached my experiment but I'm not having a lot of luck getting my questionnaires to work properly. I even tried to go back to the earlier version but that was a mistake. The newer version is much better. My experiment is a series of questionnaires. It doesn't even have anything difficult to do. I also haven't even coded in the calculations for things like qualifications or the scores on the questionnaires yet (which I would use python for).

    I tried to attach my experiment several times but it doesn't seem to work.

  • If it has the same name as the older one that you uploaded, it won't work. If the current version of your script is different from the old one, try to rename the file and upload again. If that doesn't work either, just upload it somewhere (e.g. www.filedropper.com) and post the download link here.

    Thanks,
    Eduard

  • Here you go. Had to rename it as it is already uploaded (probably older version though).

  • Sorry Patricia, but with all your discussion, I lost track of what the actual issue is here.

    I tested your script, added response to the logged variables and a linked logger after every keyboard response in your loops, and as far as I can tell, there is no issue. All the keyboard responses are present, linked either with the question, or in a separate column (gender, etc).

    Or am I missing something?

    (experiment attached)

    Eduard

  • Hey Eduard,
    The program crashes with the attached message after the handedness questionnaire.
    Not sure why this isn't happening when you run it but it happens every time I run it. It used to make it to the end of the program but now it only gets as far as the handedness questionnaire. Any help on this would be appreciated.
    It's good to know it works for you and the output is starting to look the way I want it. Now if I can get it to stop crashing on me, that would be fab!

Sign In or Register to comment.