Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

Error using OpenSesame 3.2.5


I just did the download of the new version of OpenSesame (3.2.5). I did the alterations in my project and when I tried to run the experiment, the program stopped and showed the "Oops, I did it again" message. The problem is that OpenSesame also froze and I can't scroll down or try to send the error message. What can I do to solve this?

Thank you!


  • Hi,

    I don't know what could have caused this, but let's find out:

    • Before running the experiment, make the debug window visible (Ctrl+D)
    • Run the experiment. This will probably crash as it does now, leaving the user interface deactivated.
    • In the debug window, type opensesame.enable() to reactivate the user interface. You should now be able to see the full error message and send it. Could you also post it here?


  • edited August 2018

    Hi Sebastiaan!

    I did what you ask me to. The error message is the following:

    Traceback (most recent call last):
      File "C:\Program Files (x86)\OpenSesame\lib\site-packages\libqtopensesame\", line 986, in run_experiment
      File "C:\Program Files (x86)\OpenSesame\lib\site-packages\libqtopensesame\runners\", line 256, in run
        ret_val = self.execute()
      File "C:\Program Files (x86)\OpenSesame\lib\site-packages\libqtopensesame\runners\", line 73, in execute
        if debug.enabled:
    NameError: global name 'debug' is not defined

    I also tried with different archives but the same message appears.

    Thank you for your help!

  • Ah, I see. This is a known issue caused by the External Runner. You should be able to fix this by selecting the Multiprocess Runner under Menu → Tools → Preferences.

Sign In or Register to comment.