Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

[solved] OpenSesame on multiple screens (win7)

edited March 2012 in OpenSesame

Hi Sebastiaan!

I seem to be having quite a funny problem: I used OpenSesame while I had a second monitor attached to my Windows 7 laptop. OpenSesame was open on the second screen. Now, when I run OpenSesame again (without the second monitor), it still opens on the location on the second screen, meaning I can't see it. Curiously, all the notifications (the "How would you like to start?" and "Quit" messages, for example) pop up on the laptop's screen.

Obviously, this is a bit annoying and I'm at a loss as to how to fix it (regular applications pop up on the laptop's screen, when the second monitor is disconnected, so I'm not familiar with the problem at all). Any ideas? :p

Thanks in advance!
Edwin

P.S.: I tried running OpenSesame Portable in stead, but it opens on the same location (on the imaginairy second monitor, that is).

Comments

  • edited 5:30AM

    Hi Edwin,

    Right yes, I experienced that as well at some point. Perhaps there should be a "don't restore Window position" command line option or something, because it's really annoying! Anyway, you can reset the configuration by opening a Python prompt and pasting these lines:

    from PyQt4 import QtCore
    import sys
    settings = QtCore.QSettings("cogscinl", "opensesame")
    settings.beginGroup("MainWindow")
    settings.clear()
    settings.endGroup() 
    sys.exit()

    Hope this helps!

    Cheers,
    Sebastiaan

    There's much bigger issues in the world, I know. But I first have to take care of the world I know.
    cogsci.nl/smathot

  • edited 5:30AM

    Thanks, it did the trick!

Sign In or Register to comment.