Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

Item-stack error

Hello everybody,
i have created an experiment with opensesame which contains videos. The problem is that i cannot run the experiment on my pc, except i delete the videos. When i do that, the experiment runs. On all other pcs, i download opensesame and run the experiment on an usb-stick with the videos without any problems. I downloaded opensesame once again on my pc but i still doesnt work, although my pc is new and all the videos run with for example vlc-player. I always adjust "legacy" . So it has to concern the videos in my experiment but i dont understand the error message. I send you the picture of the message. I hope you have an idea.

Best wishes
Felix!

Comments

  • Hi Felix,

    The crucial part of the error message is at the bottom, that is, the part that we can't see in your screenshot. :wink:

    The best way to post the error message is by simply copy-pasting the full text. You can use ~~~ markers to indicate that something is code when posting on the forum. Like so:

    ~~~
    # Your stacktrace here
    ~~~
    

    Cheers,
    Sebastiaan

  • Hi Sebastiaan,
    i see, lets try this...

     File "C:\Program Files (x86)\OpenSesame\lib\site-packages\libqtopensesame\misc\process.py", line 140, in run
        exp.run()
      File "C:\Program Files (x86)\OpenSesame\lib\site-packages\libopensesame\experiment.py", line 413, in run
        self.items.execute(self.var.start)
      File "C:\Program Files (x86)\OpenSesame\lib\site-packages\libopensesame\item_store.py", line 90, in execute
        self.prepare(name)
      File "C:\Program Files (x86)\OpenSesame\lib\site-packages\libopensesame\item_store.py", line 122, in prepare
        self[name].prepare()
      File "C:\Program Files (x86)\OpenSesame\lib\site-packages\libopensesame\sequence.py", line 124, in prepare
        self.experiment.items.prepare(_item)
      File "C:\Program Files (x86)\OpenSesame\lib\site-packages\libopensesame\item_store.py", line 122, in prepare
        self[name].prepare()
      File "C:\Program Files (x86)\OpenSesame\lib\site-packages\libopensesame\sequence.py", line 124, in prepare
        self.experiment.items.prepare(_item)
      File "C:\Program Files (x86)\OpenSesame\lib\site-packages\libopensesame\item_store.py", line 122, in prepare
        self[name].prepare()
      File "C:\Program Files (x86)\OpenSesame\share\opensesame_plugins\media_player_mpy\media_player_mpy.py", line 119, in prepare
        elif not self.player.load_media(path):
      File "C:\Program Files (x86)\OpenSesame\lib\site-packages\mediadecoder\decoder.py", line 162, in load_media
        self.clip = VideoFileClip(mediafile, audio=play_audio)
      File "C:\Program Files (x86)\OpenSesame\lib\site-packages\moviepy\video\io\VideoFileClip.py", line 55, in __init__
        reader = FFMPEG_VideoReader(filename, pix_fmt=pix_fmt)
      File "C:\Program Files (x86)\OpenSesame\lib\site-packages\moviepy\video\io\ffmpeg_reader.py", line 32, in __init__
        infos = ffmpeg_parse_infos(filename, print_infos, check_duration)
      File "C:\Program Files (x86)\OpenSesame\lib\site-packages\moviepy\video\io\ffmpeg_reader.py", line 250, in ffmpeg_parse_infos
        if "No such file or directory" in lines[-1]:
    IndexError: list index out of range
    Dismiss this message
    

    Best wishes
    Felix

  • Hi,

    I get exactly the same error and I was wondering if you have already a solution, since the previous post is pretty old. I checked the preferences and the packages. I cannot understand why the experiment is working in one laptop and not in another one, the one that I have to use during the testing session.

    Do you a solution?

    Thanks
    Chi

  • This looks like a bug in ffmpeg to me. @Daniel Do you recognize this?

  • Hi Sebastiaan, hi Daniel,

    the problem is still present. Do you have maybe some suggestions? We also tried with different OpenSesame versions and different video files (avi and fls) but the problem persists on that laptop.

    Cheers,
    Chichi

  • Hi all,

    Sorry for joining in so late, but this problem indeed appears to originate from within the moviepy module. An update to this module might fix this, but since I haven't updated the media player plugin for a while, I hope a newer moviepy version won't break anything else. In any case, I think it is worth the try.

    According to the instructions from http://osdoc.cogsci.nl/3.2/manual/environment/ you can update the moviepy module by issuing the following command in the OpenSesame debug window:

    import pip
    pip.main(['install', 'moviepy', '--upgrade'])
    

    Could you give this a try and let us know how it went here?

Sign In or Register to comment.