Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

Video plugin not appearing

edited February 7 in OpenSesame

I am using Opensesame 3.0 (my experiment does not run on the newest version) on ubuntu 16.04, and VLC media player 2.2.2.
I downloaded the media_player_vlc and media_player_mpy plugins using pip install (per the instructions on I've tried restarting both the program and my computer after installation, but the icons don't load onto the OpenSesame toolbar for me to use the plugin.

They are currently located in /home/[username]/.local/share/opensesame_plugins, but I noticed in the plug-in extension manager in Opensesame itself that plugins are found in /usr/share/opensesame/plugins. However, I can't drag the media_player_mpy or media_player_vlc folders into that folder. I tried to pip install them into the /usr/share/opensesame/plugins using the terminal. Even though it said that the download was successful, they don't appear in the folder.

I would appreciate any guidance. Thank you :)


  • Hi peapod,
    Installation of plugins has become much simpler. For many of them, there is a package on pip available.
    media_player_mpy for instance can be installed by

    pip install opensesame-plugin-media_player_mpy

    I wonder why your experiment doesn't work on the newer version of OpenSesame. Every version in the 3.x branch should be backward compatible, so this shouldn't give you any trouble.

Sign In or Register to comment.