Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

Problem with audio in OSWEB


I am currently trying to get to know OpenSesame and am hoping to run an experiment online in the near future. I have a test experiment (a 4IAX procedure) that I am working with. Here is the file:

It runs no problem in OpenSesame, but when I run it in a browser I get this error right after the first of 4 sound files is played:

This is the console:

I'm brand new to web development and I don't know how to fix this problem. Any help is very much appreciated.



  • Hi Beth,

    Thanks for reporting this problem. It is a known issue, and I am in the works of solving it, but haven't quite succeeded yet. You can keep track of the progress on If the issue is closed there, the problem should be solved.


  • Thanks very much

  • Hi Beth,

    See The issue should be resolved. Could you check if your experiment now works on

  • Hi Daniel,

    I just tried it out and it still stops after the first of four sound files is played. No error pops up, but it just stops. Is there anything I can send you that would help?


  • Hi Beth, thanks for reporting back. I will test it with your file tomorrow and see what causes this.

  • edited June 2019

    Hi Beth, I have found the cause of the problem. Apparently duration `sound` of the sampler item is not handled correctly by osweb. If I enter 0 or any value in milliseconds in this field, the experiment does progress normally. I hope to fix this in the next few hours.

  • Ok. I fixed the issue, but now another one incidentally pops up. Could you check your experiment again on For me on some runs the experiment completes normally, but on other runs there is an error related to the sound source being undefined. I have yet to find out why this is, and at the moment I don't have anymore time to look into it (hopefully again soon). At least you should be able to proceed with testing your experiment in osweb. For a real run I would wait until we resolved the undefined error.

  • Hi Daniel,

    Thanks! We are getting closer. It ran well for about 10 trials, then I got this error, which I think is the one you describe above:

    Thanks for your help.

    I'll wait to hear back from you when you have time to look into the problem, but there is no big rush.

    Thanks again,


Sign In or Register to comment.