Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

JASP and BayesFactor ANOVA priors

I have ran a Bayesian ANOVA in R using the BayesFactor package. I set the whichmodels option to any and I'm getting a BF for one value of ~18.50.

One of my collaborators tried this in JASP and gets a BF around ~0.8-1.3. I have tried re-running my model in R using the 'withmain' option (to make it similar to JASP), but I'm still getting a similar BF to the one I got in R originally.

I was wondering if this has something to do with the priors? I know BayesFactor uses JZS priors, but does JASP use the same? If not, does anyone have any ideas why this discrepancy may be emerging?


  • Apologies, I meant that I had originally set whichmodels to "all".

  • JASP uses BayesFactor under the hood, so they should produce the same results...

    The only thing I can think of is if the data is a repeated measures design, and the ID random intercept is miss-specified somewhere..

  • Thanks for the suggestion. This is my R code:

    iter = 500,000

     anovaBF(formula = p_correct ~ Colour*Group + id, data = Exp1_tidy, whichModels = "withmain", whichRandom = "id", iterations = iter)

    and output:

    and this is the JASP output:

  • And the JASP data format is in the wide format?

    Very weird indeed...

  • Yep, the original data was in wide format, then transformed into tidy data in R prior to the BF analysis using the following code:

    Exp1_tidy <- Exp1_wide_simple %>%

     gather(Colour, p_correct, Red:Green, factor_key=TRUE)

  • Everything seems like it should work... Sorry I couldn't be of more help...

  • Strange indeed. The results should be identical. Perhaps check to see that the descriptives match up just to make sure that the two software programs are looking at the same data?


Sign In or Register to comment.