Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

Incomplete display of a stimulus for a stimulus detection task

edited May 2016 in OpenSesame

Hello!

I have built a program using OpenSesame for a stimulus detection task for use in children. The stimulus for this task is a small box which is displayed for either 50 ms, 29 ms, or 17 ms. While the 50 ms and 29 ms stimuli appear to be displayed normally, I am experiencing issues with the 17 ms stimulus.

Unlike the long displays, the 17 ms display of the box appears to be inconsistent, such that sometimes the whole box is displayed but at other times only half of the box is displayed (ie, an incomplete display). Of note, the screen refresh on our computer is 60 hz, and it cannot be made to refresh faster.

So, I have two questions that arise from this issue. One, has anyone encountered an issue like this in a stimulus detection task using OpenSesame? Second, is there a way to fix this display issue (besides buying a computer that has a faster refresh rate)? Any assistance would be greatly appreciated!

Cheers

Comments

  • edited 4:56PM

    Hi clb!

    These inconsistencies could have multiple causes:

    • It can be back-end related. Try for example switching to xpyriment if you haven't already done so.

    • It can be caused by the stimuli not making the refresh deadline in time. Try setting the stimulus duration to a slightly lower duration.

    • It can be caused by the way you generate your stimuli, if you haven't done so already try to construct the stimuli beforehand in a prepare-run strategy.

    • It can simply be some hardware problem intervening with OpenSesame, have you tried the experiment on a different set-up?

    Best,
    Laurent

Sign In or Register to comment.