Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

Opensesame not running my experiment on tablet

Hi all,

I created a lexical decision task to run on an Android tablet. It works on perfectly on the computer but the android version of Opensesame crashes every time I try to open the it on the tablet. I tried running the debug, but I can't access it because my keyboard doesn't allow to insert underscores (I've tried multiple third party keyboards for this but none of them seem to work).

Here is the script of the file. Because the task involves changing the space between letters and I couldn't find a way to modify it with the app, I created pictures and use them as the stimulus.

The tablet I'm working with is an Acer Iconia Tab 8 A1-840FHD-197C 8.0-Inch Full HD Tablet, running on Android Kitkat.

I was wondering if anyone can help me figure out what is wrong.


  • What's in the crash report? Maybe you are missing libraries or something.

  • the tablet doesn't show a crash report, the program just closes. It happens right after I insert the location of the log file.

  • At this point, it is hard to say what's happening.

    Can you try launching opensesame with --debug option from terminal/command line?

  • how do I do that?

  • edited February 2017

    Well, android should have a terminal (I don't have tablet, nor a phone with android), type there this --> opensesame --debug
    This should start the program in the debug mode and print all messages in the terminal, once it crashes, it will also print messages, which you can copy paste here.

  • I downloaded app that works as a terminal and typed "open sesame --debug" an it says that it cannot be found. Anything else you recommend?

  • This is what the app says:

    u0_a107@ducati2fhd:/ $ OpenSesame --debug
    /system/bin/sh: OpenSesame: not found
    127|u0_a107@ducati2fhd:/ $ opensesame--debug
    /system/bin/sh: opensesame--debug: not found
    127|u0_a107@ducati2fhd:/ $ opensesame
    /system/bin/sh: opensesame: not found
    127|u0_a107@ducati2fhd:/ $ OpenSesame
    /system/bin/sh: OpenSesame: not found
    127|u0_a107@ducati2fhd:/ $ opensesame --debug
    /system/bin/sh: opensesame: not found
    127|u0_a107@ducati2fhd:/ $ opensesame-debug
    /system/bin/sh: opensesame-debug: not found
    127|u0_a107@ducati2fhd:/ $ opensesame-debug.txt
    /system/bin/sh: opensesame-debug.txt: not found
    127|u0_a107@ducati2fhd:/ $
    127|u0_a107@ducati2fhd:/ $

  • Hi Cesar,

    Information about how to run an experiment on Android can be found here:

    Your first problem is that you simply haven't selected the droid backend. But you need to take other things into account as well, so it's important to read that page carefully.


  • edited February 2017

    Thank you Sebastian, it worked!

    but know I can't find where the app is saving the cvs file for my experiment or the example task. It is not saving it anywhere inside the internal storage or the sd card.

    can you help me with that?

  • I just tried it on my computer and the file is created perfectly but I still can't find it in my tablet.

Sign In or Register to comment.