Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

Enter key on numeric keypad is not registered as enter on OSX

edited February 2017 in OpenSesame

I have some text_input and base forms, where participants enter numbers. All this forms have return_accepts=yes. Pressing the enter key on the numeric keypad portion of a Mac keyboard (A1243) merely prints an uninterpreted character and the experiment doesn't advance. In addition, the form just hangs, and if you press the enter key on the main keyboard, the experiment still doesn't advance.
The latter issue might be because I am using a in_line for checking input:

    while True:
        # If the response has the value 'None':
        if var.other_por_yes == 'no' or var.other_por == '':
            # Rerun the item (after preparing it):

        # Else, the experiment advances normally.



Sorry for double posting. Don't know how to delete it.


  • Hi Hike,

    Thanks for reporting this. I've added an issue on OpenSesame's issue tracker, and we will look into this. Good choice to print the numpad enter key's output. In the meantime you can use that to listen for its presses, but this should be fixed in one of the next releases.

    It is easy to determine for the second issue if your script is the cause. If you create a form without using script, does the main enter key still not advance the form?

  • Hi Daniel,

    Thanks for helping.

    I just tested on a macmini to make sure that the script is not involved in the first issue. I pulled a text_input into the default template and got the same weird character.

    The second issue is due to the script.


  • Just an update, the same mac keyboard used on a dell laptop running ubuntu, works as it should -- both enter keys on the main keyboard and the numeric keypad advance the experiment. Openseasme version is the same, so this is defiantly an issue with OSX (who knew OSX had some many issues!)

Sign In or Register to comment.