Avatar

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

Daniel

About

Username
Daniel
Joined
Visits
310
Last Active
Roles
Member, Administrator, Moderator
Thanked
5

Comments

  • I do get a different error though, and I am using Pixi.js 4.8.8 (I updated it this morning): https://forum.cogsci.nl/uploads/802/EN4CC661MDNL.png The sound however plays normally, and the experiment progresses without problems too. Regardless, this …
  • Alright, when I try to run it in Firefox I get the error right away. Chrome just works for me; do you experience the same regarding browser usage? At least I have something to go on now. Will get back about this soon.
  • Alright, that's a start. I went through the experiment 3 times and it didn't occur. Can you describe the steps to reproduce it, or does it happen intermittently?
  • Hi Rissa, I ran your experiment without major problems. There are some weird error messages on the console, but these errors don't appear to break anything as your experiment runs normally. Which version of osweb are you using? And did these errors …
  • Thanks Rissa, I hopefully have some time to look at this tomorrow.
  • Hi Rissa, would it be possible for you to attach your experiment here, so we can run it to try and reproduce your error? Best, Daniel
  • Hi Lucie, Sadly these things are not possible yet. Osweb is in a very early stage of development and we're gradually building and and adding extra functionality, but I don't see what you are asking for added soon. If you'd like to have far-fetching …
    in javascript Comment by Daniel June 12
  • detecting adblockers can be quite daunting, but shouldn't we warn people that experiments might not work correctly if adblockers are enabled? The flipside of the coin is that people may become wary that osweb may feed them ads if we issue such warn…
  • , can you tell me your e-mail address and name in a private message so I can create an account for it?
  • Hi Samaah, I can't seem to reproduce the error, on my Jatos installation the experiment just works fine, so it's hard for me to pinpoint what is going wrong. There are only 2 places where the substr function is used, which is mentioned in your erro…
  • Hi Saamah, I'm actually looking into it now and it just works for me, so the error must occur elsewhere. The `Error reading osexp: Error: Could not read remote osexp, TypeError: e.substr is not a function osweb.1.3.1.bundle.js:1:102711 Give me the i…
  • This must be a regression error. I will look into it soon!
  • This sounds familiar indeed and I think this issue has also been fixed by our recent work on the touch_response item. I did a quadrant test last time, and it worked as it should then, but let's test it again to be sure though with 1.3.1.
  • Robbert, you're one fire.. Thanks for testing the osweb module so extensively (and thus giving it a chance). An issue has been created at Github: https://github.com/shyras/osweb/issues/134. You can keep track of the progress there. Feel free to (als…
  • > Strangely, running the app in debug mode (like you suggested) completely eliminates the problem. Is there a reason why I wouldn't want to use the debug mode? That is very weird. What happens if you start OpenSesame from the terminal, but without…
  • you're right. Both Psychopy and Expyriment work well again now on my Mojave installation. They really didn't at first and I just got to see a black screen after starting an experiment, so maybe Apple fixed something in one of their patch releases o…
  • Now you should post the results of everyone's favorite teletubby somewhere...
  • Hi peapod, Installation of plugins has become much simpler. For many of them, there is a package on pip available. media_player_mpy for instance can be installed by pip install opensesame-plugin-media_player_mpy I wonder why your experiment…
  • These problems are likely caused by Mojave deprecating OpenGL in favor of Metal. https://developer.apple.com/macos/whats-new/ (all the way at the bottom) https://appleinsider.com/articles/18/06/04/opengl-opencl-deprecated-in-favor-of-metal-2-in-ma…
  • I have updated to Mojave myself now, and OpenSesame indeed shows some quirks, although not as serious as the ones you describe. The issues appear to be mostly related to the hardware acceleration of the interface, and OS backends in my perception. I…
  • Fixed in v1.1.1 The culprit was the file extensions of the image files in the pool being uppercase. This caused them to not be correctly recognized and processed as images. I made the extension check case-insensitive and now the experiment runs nic…
  • Hi Noah, it is not entirely clear to me where you experience your problem. Is this with opening OpenSesame itself, or when opening/running an experiment. I upgraded to Mojave myself yesterday and the OpenSesame interface appears to work fine, while …
  • I'll have a look at this soon!
  • Hi guys. I think this has to do with the Macos Mojave update. I haven't updated to Mojave yet and I plan on waiting a few patch updates (the first few releases of a new Macos version are always quite messy in my experience), so I have no way to repr…
  • I'm starting to sound like a broken record, but I really need to fix this plugin. It is built on top of pymedia, which is a library of which the support and development have stopped years ago. OpenSesame contains the facilities to built a better and…
  • That, or I'll simply have to downgrade pip again to the same version as in Windows. I'm leaving this decision to @sebastiaan
  • I looked into this, and I guess the Mac version has a newer version of pip (version 18) which changed its internal structure a bit. Executing these lines of code instead did the trick for me on MacOS: import pip._internal pip._internal.main(['ins…
  • Hi Guys, I have no idea where this error comes from. I'll have a look when I'm back on my Mac again. Regards,
  • Hi Roberto, Sorry for my slow response. I have never heard of or seen this problem before. My knowledge of pygaze is too limited to know what is does for media_player_mpy to possibly fail. Since it works for you on one of your laptops and not on …
  • Thanks for reporting this @DahmSF. I haven't had this problem myself, so I hope I'm able to reproduce it. It appears to be a repaint problem to me, although the crash afterwards suggests it may be something more serious. What Mac model are you …