Avatar

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

Daniel

About

Username
Daniel
Joined
Visits
330
Last Active
Roles
Member, Administrator, Moderator
Thanked
7

Comments

  • Hi Darwin, The best way to find out how the media player item works is to check out its documentation. Once you have added the media_player_mpy to your experiment's timeline, you can access its help page by clicking the question mark button in the t…
  • Hi Shahao, It's difficult for me to look into this, because my MacBook is too old to upgrade to Catalina, so I can't get any first-hand experience with the error. Googling the error message (in particular the integrity part) did not deliver a lot of…
  • Thanks Rissa, Never worry about Internet Explorer. Its market share is dwindling and close to zero nowadays, and many other applications stopped have already stopped developing for it completely in favor of MS Edge, because IE is ancient and increas…
  • I don't think so. Let's do so
  • Ok. I fixed the issue, but now another one incidentally pops up. Could you check your experiment again on http://osweb.cogsci.nl? For me on some runs the experiment completes normally, but on other runs there is an error related to the sound source …
  • Hi Beth, I have found the cause of the problem. Apparently duration `sound` of the sampler item is not handled correctly by osweb. If I enter 0 or any value in milliseconds in this field, the experiment does progress normally. I hope to fix this in …
  • Then I'm confused as to why this goes wrong. I'd also expect the whole experiment to crash and stop working if it were a syntax error to be honest...
  • Hi Beth, thanks for reporting back. I will test it with your file tomorrow and see what causes this.
  • Hi Beth, See http://forum.cogsci.nl/discussion/comment/16731/#Comment_16731. The issue should be resolved. Could you check if your experiment now works on http://osweb.cogsci.nl/?
  • Hi Rissa, I dived into this and there are two errors occurring here: The `osweb has stopped running due to a fatal error` message is caused by the `break_if` field in `text_lp_7`. In your practice_trial loop the `[response_t7]` field is initialized …
  • Hi Beth, Thanks for reporting this problem. It is a known issue, and I am in the works of solving it, but haven't quite succeeded yet. You can keep track of the progress on https://github.com/shyras/osweb/issues/151. If the issue is closed there, th…
  • I do get a different error though, and I am using Pixi.js 4.8.8 (I updated it this morning): https://forum.cogsci.nl/uploads/802/EN4CC661MDNL.png The sound however plays normally, and the experiment progresses without problems too. Regardless, this …
  • Alright, when I try to run it in Firefox I get the error right away. Chrome just works for me; do you experience the same regarding browser usage? At least I have something to go on now. Will get back about this soon.
  • Alright, that's a start. I went through the experiment 3 times and it didn't occur. Can you describe the steps to reproduce it, or does it happen intermittently?
  • Hi Rissa, I ran your experiment without major problems. There are some weird error messages on the console, but these errors don't appear to break anything as your experiment runs normally. Which version of osweb are you using? And did these errors …
  • Thanks Rissa, I hopefully have some time to look at this tomorrow.
  • Hi Rissa, would it be possible for you to attach your experiment here, so we can run it to try and reproduce your error? Best, Daniel
  • Hi Lucie, Sadly these things are not possible yet. Osweb is in a very early stage of development and we're gradually building and and adding extra functionality, but I don't see what you are asking for added soon. If you'd like to have far-fetching …
    in javascript Comment by Daniel June 12
  • detecting adblockers can be quite daunting, but shouldn't we warn people that experiments might not work correctly if adblockers are enabled? The flipside of the coin is that people may become wary that osweb may feed them ads if we issue such warn…
  • , can you tell me your e-mail address and name in a private message so I can create an account for it?
  • Hi Samaah, I can't seem to reproduce the error, on my Jatos installation the experiment just works fine, so it's hard for me to pinpoint what is going wrong. There are only 2 places where the substr function is used, which is mentioned in your erro…
  • Hi Saamah, I'm actually looking into it now and it just works for me, so the error must occur elsewhere. The `Error reading osexp: Error: Could not read remote osexp, TypeError: e.substr is not a function osweb.1.3.1.bundle.js:1:102711 Give me the i…
  • This must be a regression error. I will look into it soon!
  • This sounds familiar indeed and I think this issue has also been fixed by our recent work on the touch_response item. I did a quadrant test last time, and it worked as it should then, but let's test it again to be sure though with 1.3.1.
  • Robbert, you're one fire.. Thanks for testing the osweb module so extensively (and thus giving it a chance). An issue has been created at Github: https://github.com/shyras/osweb/issues/134. You can keep track of the progress there. Feel free to (als…
  • > Strangely, running the app in debug mode (like you suggested) completely eliminates the problem. Is there a reason why I wouldn't want to use the debug mode? That is very weird. What happens if you start OpenSesame from the terminal, but with…
  • you're right. Both Psychopy and Expyriment work well again now on my Mojave installation. They really didn't at first and I just got to see a black screen after starting an experiment, so maybe Apple fixed something in one of their patch releases o…
  • Now you should post the results of everyone's favorite teletubby somewhere...
  • Hi peapod, Installation of plugins has become much simpler. For many of them, there is a package on pip available. media_player_mpy for instance can be installed by pip install opensesame-plugin-media_player_mpy I wonder why your experiment…
  • These problems are likely caused by Mojave deprecating OpenGL in favor of Metal. https://developer.apple.com/macos/whats-new/ (all the way at the bottom) https://appleinsider.com/articles/18/06/04/opengl-opencl-deprecated-in-favor-of-metal-2-in-ma…