Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

Can't reinstall OpenSesame on Mac High Sierra 10.13.6

Hello everyone, I tried to uninstall and make a fresh installation of OpenSesame after some strange problem with the Mousetrap plugin (I had the plugin installed, but kept getting ImportError: No module named PyMT_response).

So I uninstalled OpenSesame from my Mac the usual way - just dragging the icon to the trash and emptying it. After that however I can't get any version to install - tried 3.2.7 and 3.2.6 (this one worked before the uninstall). For both I get the same error after installation and trying to run - “OpenSesame” is damaged and can’t be opened. You should move it to the Trash.

Does anyone know what could be the problem? Is that the right way to fully uninstall OpenSesame on Mac?

I'm trying to leave erasing my disk and doing a fresh install of High Sierra as a last resort measure.


  • edited April 2019

    This appears to occasionally happen in MacOSX without any particular rhyme or reason (although, it probably has to do with increasingly pushing developers to use the App Store so they can make more money). I haven't used the DMG file myself recently because I installed OpenSesame in my conda environment which appears to be the smoothest, but there are a few things you can try.

    • The first thing I'd try is what you already have: downloading again and binning the old version; so that doesn't help.
    • Silly, but rebooting sometimes helps.
    • Check for software updates.

    If these don't work, you will have to go into the Terminal I'm afraid, but it's pretty straight-forward. Open the terminal (it's in utilities if you can't find it) and type the following:

    xattr -cr /Applications/

    (This is assuming that OpenSesame is in your Applications folder; replace with your path to the application if necessary). This removes all the extended attributes -which are sort of like metadata- of the app and its underlying contents. That should do the trick.

  • The last advice worked! Thanks a lot, cesco 🍻 I just typed :

    xattr -cr /Applications/

    in my terminal and I was able to start OpenSesame again.

    However I can't seem to fix the error I was trying to get around in the first place. I have the Mousetrap plugin installed (it's present in the plugins and extension manager) and I keep getting ImportError: No module named PyMT_response when I try to run my experiment. And it used to run without any issues. I'm assuming the plugin files got corrupted somehow (probably an OS bug again), but can't figure out how to make a clean install of all the plugins.

    Has anyone else encountered a similar error?

Sign In or Register to comment.