Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

Test-drive OpenSesame 0.27 "Frisky Freud"!

edited October 2012 in OpenSesame

Pre-release packages of OpenSesame 0.27 "Frisky Freud" are available. This release has a number of exciting new features, such as:

  • An new back-end, based on Expyriment
  • Form functionality
  • Improved support for localization (e.g., non-Western alphabets, translations, and support for non-Qwerty keyboard layouts)
  • New templates based on well-known stimulus sets

You are encouraged to try out Frisky Freud, report bugs, and help to make the best release of OpenSesame yet!

Disclaimer: Keep in mind that this a pre-release, and you can expect to encounter bugs.

image

Italian translation courtesy of Andrea Epifani

Comments

  • edited November 2012

    Also available as a portable version as from now. See here or click (version pre30) to download.

  • edited 3:23AM

    When I try and run the questionnaire sample experiment, I get the following error after the first answer:

    Error: Runtime error
    Description: usanitize() expects first argument to be unicode, not ""

  • edited 3:23AM

    Hi Jákub,

    Thank you. Indeed, the multiple_choice plug-in is broken in OpenSesame 0.27. However, please see my post here for an alternative.

    Cheers!
    Sebastiaan

  • edited 3:23AM

    Hello Sebastiaan.
    Thank you very much for your prompt reply. Will the plugin be fixed in the final version of 0.27, or are you moving away from this plugin?

    Best regards,
    Jákup

  • edited 3:23AM

    Both, actually. Since this is only a minor bug, I'll fix it for those who still want to use the questionnaire plug-ins. But minor updates aside, the forms are intended to fully replace the questionnaire plug-ins.

  • edited 3:23AM

    There seems to be some bug in the form_text_input item. When using it, even when simply using the default template, the following error message is displayed, when you try and edit the logger's script and press "Apply and close":

    "unbound method var_info() must be called with form_base instance as first argument (got qtform_text_input instance instead) (Edit the script to fix this)"

    I'm using the pre-32 build.

    Best regards,

    Jákup

  • edited 3:23AM

    Ah, thanks for pointing that out. I encountered a similar bug a while back. It should be fixed as of 0.27~pre34. But the issue it's kind of difficult to reproduce, so let me know if it still occurs.

  • edited 3:23AM

    I love it when you put up a new pre-release package! I get so excited and can't wait to get home and try it out :)

    Best regards.

    Jákup

Sign In or Register to comment.