Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

[open] Can't open the OpenSesame

edited October 2015 in OpenSesame


I encounter some strange error.
After my first install of opensesame (3.0.1) on Mac, opensesame doesn't open from the next time.
When I open opensesame from the sourse using 'python opensesame', the error occurred as below.

Traceback (most recent call last):
  File "opensesame", line 97, in <module>
  File "/Users/Desktop/OpenSesame-release-3.0.1/libqtopensesame/", line 207, in resume_init
  File "/Users/Desktop/OpenSesame-release-3.0.1/libqtopensesame/", line 357, in restore_state
    for path in cfg.recent_files.split(u";;"):
AttributeError: 'QPyNullVariant' object has no attribute 'split'

How can I open again?



  • edited 12:40AM

    This seems to be due to some difference in the way that Mac OS (as compared to Windows and Linux) handles configuration saving. If you start OpenSesame as follows (assuming you're running from source), you should be fine again:

    python opensesame --start-clean

    This error may come up again and again, I'm not sure, but using the --start-clean argument should fix it every time.


    There's much bigger issues in the world, I know. But I first have to take care of the world I know.

  • rrrrrr
    edited 12:40AM

    Hello sebastiaan,

    Thank you for your prompt reply.

    I did it!

    Can I start opensesame by other way?


  • rrrrrr
    edited 12:40AM


    I solved the second question by myself.

    I found the OpenSesameRun makes it possible.

    Thank you a lot!


  • edited 12:40AM

    I had a look at it in the code. Somehow at places where just an (empty) string is expected, a QPyNullVariant is returned on the mac, which doesn't have a split() method. A call to the split() method consequently crashes the program. I added some fixes for this, which should be added in the next maintenance release and hopefully prevents these errors in the future.

  • Hello,

    I am trying to run an ultimatum game on the OpenSesame software using the psynteract plugin. However, when I run the experiment on the experimenter PC, it states unexpected error. Here is a screenshot of the same. Please let me know how to solve it.

    Thank you

  • I'm pinging @Pascal, one of the developers of Psynteract.

    There's much bigger issues in the world, I know. But I first have to take care of the world I know.

  • Hi there,

    the error probably occurs because psynteract tries to connect to an open session on the psynteract server and it seems that there is no open session. You could either try to open one or activate the "Offline test mode" option in the psynteract_connect item.



    Thanked by 1Prashantig
Sign In or Register to comment.