Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

General Script resets 'fullscreen' to "no".

Hi folks,

I've set my resolution to match that of the monitor being used but when I run (via the big green button) the experiment appears in a small window.

I've read other threads that suggest changing 'fullscreen' in the General Script to "yes" and I have done so but it immediately reverts to "no" when the experiment is run or, indeed, when I open another tab. Which results again in a small window and no fullscreen.

Any ideas what I'm doing wrong?

Thanks for your time as always,

Boo.

Comments

  • Hi Boo,

    I've set my resolution to match that of the monitor being used but when I run (via the big green button) the experiment appears in a small window.

    I suspect that the operating system uses display scaling, which is a way to automatically magnify stimuli on displays with an extremely high resolution. This can lead to strange effects, such as the experiment window being shown in the corner of the screen (even when run fullscreen). If so, you can fix this by disabling display scaling in the operating system.

    I've read other threads that suggest changing 'fullscreen' in the General Script to "yes" and I have done so but it immediately reverts to "no" when the experiment is run or, indeed, when I open another tab. Which results again in a small window and no fullscreen.

    The fullscreen option is set automatically by OpenSesame when you execute the experiment, so there's no need to do this manually. And, in any case, it's probably not related to your issue.

    Cheers!
    Sebastiaan

  • edited October 2018

    Hi Sebastiaan,

    I'll try your solution tomorrow!

    Thanks for your help,

    Boo.

  • Hi again,

    I found time to try this fix. It worked!

    Thanks again,

    Boo.

Sign In or Register to comment.