Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Supported by

Will OpenSesame keep working if I upgrade to Ubuntu 16?

edited May 2016 in OpenSesame

Initially I tried to install OpenSesame on Ubuntu 16.04 but it failed. So I downgraded my OS to Ubuntu 15.10 and then I could install OpenSesame without problem. Any possible reason why it didn't work on Ubuntu 16 back then? And is it safe to upgrade to Ubuntu 16 now? Thanks!


  • edited 11:18PM


    Did you try the no-install-required version of opensesame? You can download it here: under 'advanced downloads'. I don't work on Ubuntu myself, so I don't know what may be causing your problem, but you could at least check if OpenSesame works this way. (After downloading, there will be a .exe in the folder).



  • edited 11:18PM

    The Cogsci PPA has been updated for 16.04 (maybe it wasn't when you first tried?), so OpenSesame should install just fine. If you encounter a problem, let us know.

    After downloading, there will be a .exe in the folder

    .exe files are only for Windows. Under Ubuntu you usually install from a so-called repository, kind of like the Google Play Store for Android.

  • edited 11:18PM

    I tried installing on a freshly installed Ubuntu 16.04 LTS following these instructions.
    I also did a sudo apt-get upgrade but I get this error:

    jdh@jdh-HP-ProDesk-600-G1-TWR:~$ sudo apt-get install opensesame
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    The following packages have unmet dependencies:
     opensesame : Depends: python-support (>= 0.90.0) but it is not installable
                  Depends: python-qprogedit (>= 3.0.0) but it is not going to be installed
                  Recommends: python-serial (>= 2.3~) but it is not going to be installed
                  Recommends: psychopy (>= 1.64.0) but it is not going to be installed
                  Recommends: python-pyaudio (>= 0.2.4) but it is not going to be installed
                  Recommends: python-imaging (>= 1.1.7) but it is not going to be installed
                  Recommends: python-opengl (>= 3.0.1) but it is not going to be installed
                  Recommends: expyriment (>= 0.5.2) but it is not going to be installed
                  Recommends: ipython-qtconsole (>= 0.12) but it is not going to be installed
                  Recommends: datamerger but it is not installable
    E: Unable to correct problems, you have held broken packages.


  • edited 11:18PM

    Ok, I'm going to look into this. I guess it has to do with the switch to Python 3 as the default Python in Ubuntu 16.04. For now, you could also consider using the opensesame-james repository, which has the development versions of OpenSesame 3.1 and definitely does work on Ubuntu 16.04. However, it is of course a development version, so all the usual disclaimers apply.

  • edited 11:18PM

    Thanks for the replies Sebastiaan. Looks like Jarik has the exact same problem as I did. Personnaly I will stick to Ubuntu 15.10 because in addition to the OpenSesame issue there seem to be no working driver for my wifi card on Ubuntu 16.04. But it's great that you're looking into it for other Ubuntu users.

  • edited 11:18PM

    Ok, there was indeed a dependency issue in Ubuntu 16.04. This is resolved now, so you can again install OpenSesame 3.0.7 through the regular ppa:

    Expyriment doesn't install through the repository, but you can install it with:

    pip install expyriment

    By the way, OpenSesame identifies itself as a beta, but it's not: This is due to clumsy packaging and version numbers on my part.

    Hope this is useful!

  • edited 11:18PM

    Works like a charm!

    Thanks, Jarik

Sign In or Register to comment.